New Posts  All Forums:Forum Nav:

Incubator help

post #1 of 5
Thread Starter 

Looking for advice.  I have built a home made cabinet incubator.  its 32 " tall by 16" wide, by 18 Inches deep.  I have installed an Incukit with the basic thermostat on the top of the cabinet in the center.  I set the stat to 99.5 degrees.  The sensor is located at the top close to the heater.  My problem is if i put a digital thermostat on the top egg shelf, it reads 104-106.  i have added extra air flow holes and the temperature is so irradic all over the incubator. Im not sure what else to do. I was led to understand this unit if you just put it in a box and set the temperature, because of the fan, heater combo, it would regulate it very nicely.  Its not the case.  I had it set based on the sensor temperature off of the t-stat.  it was reading 99.5.  so i set 160 eggs.  They all started to form, but i lost them all.  I put the digital stat in and realized how hot it was.  it doesnt make sense since the stat is set to and shuts off at 99.5.. Any advice?  Thanks,

Darren

post #2 of 5

Are you saying there is a huge variance in temperature inside the cabinet? Improve air circulation. Or are you saying the thermostat is off and you get a reading of 104 F right in front of it too? Change the thermostat setting to 94.5 F. That's two different problems with different solutions. I'm not following what your thermometer readings are and where you've taken them I guess. I know the Incukit is preset and believe has ability for small adjustments but there is nothing saying it's set right at 99.5 F. 

Everybody talks about the weather, but nobody does anything about it.

 

-Charles Dudley Warner

Reply

Everybody talks about the weather, but nobody does anything about it.

 

-Charles Dudley Warner

Reply
post #3 of 5

I've not used the Incukit, but I'll base my comments on my experience with my cabinet incubator.

 

If the thermometer is working properly, then it is regulating the temperature based on where the thermostat is located.

 

Did you place the heater on the top of the cabinet so it is blowing down on the eggs? If so, then the air has cooled by the time it comes back up the where your thermostat is located.

 

Try moving the heater to the rear wall of the cabinet so it blows over the water container and place the thermostat closer to where the eggs will be located. If it's not possible to move the thermostat, then you'll need to get a second thermometer and place it in the egg trays.  Run the incubator to determine the temperature of the eggs and adjust the Incukit settings to get 99.5-100 at the eggs.

 

I really think once you get larger than the styrofoam incubators the air flow needs to be circular inside the cabinet instead of downward.  It's a large volume of air to heat and it needs to stay in motion to stay consistent.

 

You may need to add a second fan.  125 watts of heat is enough for that size of cabinet. Mine is about that size and the fan is the same as what is in a kitchen hood exhaust. Lots of air flow inside there.

 

Good luck with it.

post #4 of 5
Thread Starter 

I have the fan on the top, so ill maybe move it to the back of the cabinet.  The digital stat that comes with it is set to 99.5.  and my sensor for that stat is located at the top near the top shelf of eggs.  The problem is that the digital inuckit stat says 99.5 on the top shelf, but my own store bought stat says 104-106 on the middle shelf which is only 6" below the top one.  The shelves are wire mesh, so there is lots of airflow.  ill try post of picture of the layout. Thanks for the help/advice.

post #5 of 5
Thread Starter 

any ideas.  so i now have mounted the incukit on the top of the incubator.  i have added a fan in the bottom to circulate more air.  If i set the incustat to 97, the top shelf reads 102, and the bottom shelf of 3 reads 98.5.  the shelves are spaced 6" apart, i dont get why i cant get even heat distribution.  i had the distribution 1 degree different, but as soon as i loaded the shelves with eggs, i had a 5 degree difference from top, being the hottest, to bottom being lowest, and i cant even set the incustat to 99.5, i have it set to 97............................

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Incubating & Hatching Eggs