BackYard Chickens › BYC Forum › Raising BackYard Chickens › Incubating & Hatching Eggs › Incubator Troubleshooting
New Posts  All Forums:Forum Nav:

Incubator Troubleshooting

post #1 of 3
Thread Starter 

I'm new to incubating and I've made a simple one with homemade materials so that is really amounts to nothing more than a really hot and humid brooder. 
Unfortunately I cannot get the humidity up and I was wondering if there are any trouble shooting tips the you, O Gurus of incubating, could give me. 

My set up is this:
One 10 gallon rubbermaid container with lid not fastened containing approximately 1.5 inches of water and a glass pie pan holding up a small plastic "shoebox" into which my eggs will be housed.  I have a thermometer and humidity monitor in with where the eggs would be.  My heat source is at the moment a 60W spot-gro bulb that is approximately 10-12 inches above the eggs. 

The only air space open at the moment is a hole in the lid through which the lamp sets and the lid is also not latched onto the rubbermaid box because part of the handle on one side is cut out to make room for the clamp portion of the lamp. 

Could my air conditioner be responsible for my lack of humidity? It's stuck at 41% but my temperature is 104° so I'm not sure what to do.
I have created a window on the side of the incubator with laminating sheets but the temp and humidity are still holding steady and I'm debating on covering the hole with the same material and just letting the lamp shine through, if that would work ?

I do have a 40w "reveal" light bulb I could use if wattage is causing the temperature problem, but it's not a heat bulb.  yesterday i was using a desk lamp with the 40w bulb and it wouldn't go past 85° but the lamp also had several slots placed at intervals in the top of the lamp for heat control.  This morning I switched to a white brooder bulb in a clamp lamp and it got way to hot (113°) but my humidity was still fairly low, maxing out at 45%. so I went to Lowes and bought a smaller clamp lamp and the 60w spot-gro bulb. 

My next step is to try the 40w to see if it will get up to 102°.  I'll let you know, thanks for the help!

Stonefruit Farm; home to 1 BR, 1 NHR, 2 GLW, 2 EEs, 2 Red Comet, 2 JGs, 1 Ameraucana, 5 Ancona ducks, 9 French Angoras and 1 Dingo
Reply
Stonefruit Farm; home to 1 BR, 1 NHR, 2 GLW, 2 EEs, 2 Red Comet, 2 JGs, 1 Ameraucana, 5 Ancona ducks, 9 French Angoras and 1 Dingo
Reply
post #2 of 3

try adding a spong to the water container for more surface area.  I read this on a few different posts to help with this problem.

post #3 of 3

I use Scott dish washer sponge work just fine.  Try to move closer to the fan airflow to increase humidity.


Edited by speedy2020 - 8/5/10 at 10:32pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Incubating & Hatching Eggs
BackYard Chickens › BYC Forum › Raising BackYard Chickens › Incubating & Hatching Eggs › Incubator Troubleshooting