0 hatch percentage!!!

Discussion in 'Incubating & Hatching Eggs' started by dlockey, Apr 7, 2012.

  1. dlockey

    dlockey Out Of The Brooder

    93
    0
    29
    Nov 7, 2011
    [​IMG] We need help!! Last year we got into chickens, got a 3 egg, $22 incubator, the kind kids use at school. We hatched one chick, the others were developed, but dead. So, last month, we put 45 eggs in our new toy, a Farm Inovator incubator. Some eggs were from a friend, he has hatched some as well. The others were from our guys/girls, and some we were not sure if they were fertile or not. But others we were pretty sure were fertile.

    So, we put them in after running the bator for a day. Temp was 100, and humidity was 70 ish percent. We candled them all along, saw but never saw any veins, many eggs were very porous, a couple had blood spots. Never saw anything else.

    We began breaking them open a few every other day or so. They were all plain raw eggs, There was a day when the temp went up to 104 and another time down to 95. We struggled to keep temp stable, but it mainly was between 98 and 101.

    Does anyone have any suggestions? Obviously, we did something or maybe everything wrong!! We appreciate any help !
     
  2. Oceanseve

    Oceanseve Chillin' With My Peeps

    943
    8
    143
    May 23, 2008
    Guthrie, OK
    70 is hatching humidity, that's really high for incubation. Do you have multiple thermometers?
     
  3. dlockey

    dlockey Out Of The Brooder

    93
    0
    29
    Nov 7, 2011
    What should the humidity be for incubation? Is there a table somewhere that tells you where it should be at what point during the entire process? It has a built in thermometer, that is the only one we used. We are thinking that one issue was that the room it was in, has a large swing in temps during the day.
     
  4. Oceanseve

    Oceanseve Chillin' With My Peeps

    943
    8
    143
    May 23, 2008
    Guthrie, OK
    There are tons of guides, problem is most don't say the same thing. It's kind of a matter of opinion, but I've never seen one recommend going over 60 for incubation. If you look at the sticky on the top of the incubation forum there are some good links. There's another good link that's not on the sticky. I'll see if I can find it and post if I can. Some people swear by dry hatching and not adding any water. The reason I believe in multiple thermometers is you never know when with one if it's wrong, which happens. I have two thermometers and two hygrometers. One of my hygrometers at first was way wrong and I had to replace it.

    If you are pretty sure they were fertile, sounds like the problem is probably temp related for none of them to develop at all. I'd get another couple of thermometers and compare. Humidity should effect water loss as they get larger, if the water loss doesn't happen properly they won't hatch, but development should have started. Then again this is all book talk, I just had my first hatch this week and failed pretty miserably. I'm going to sell my cheap incubators and get a self regulated one to avoid the temp swings which I think was my biggest problem, too. Good luck!
     
  5. cashdl

    cashdl Chillin' With My Peeps

    2,181
    35
    201
    Nov 25, 2008
    Willits
    If you never saw any development at all then they were not fertile. Even with high humidity and high temp there should have been some sort of development.

    This is just my two cents but I incubate at 25% humidity and hatch at 55% to 60% humidity. I also have an incubator and a hatcher running 24-7, but even when I used little styrofoam incubators, I just raised the humidity for hatch by adding water to the trays.

    Lanae
     
    Last edited: Apr 8, 2012
  6. cmfarm

    cmfarm Chillin' With My Peeps

    1,100
    14
    164
    May 3, 2010
    Elgin, TX

    I have to agree, it sounds like your eggs weren't fertile.
     

BackYard Chickens is proudly sponsored by