brinsea octagon 20 eco problems......Rust causing bad hatch results?????

Discussion in 'Incubating & Hatching Eggs' started by spish, Aug 7, 2013.

  1. spish

    spish De Regenboog Kippetjes

    1,847
    12
    173
    Apr 7, 2010
    Belgium
    ive had my brinsea oct eco 20 for just over a year. i Always had briljant results in the beginning but this year every hatch from the brinsea eco 20 has been terrible (maybe 1 or 2 out of 28 eggs hatching) i have 3 different machines and was only having problems with this one so i decided to open it all up to give it a really thourough disinfecting. opened up the top half, took out the fan and all clened it all bit by bit. opened up the big yellow bottom half of the machine and was utterly disgusted. there are three pieces of foam in there and a big metal bar along the bottom (for weight?) the bar is totally rusted and disintergrating, the 3 foam pieces are rotten and covered in mould, no wonder im having problems! apparatly water can leak into the bottom half and cant get back out...what an awful design!!

    ive looked on the brinsea site but they dont appear to sell this foam and metal bar as extras.....any one have any idea if i can use the machine without these pieces?
     
  2. cubalaya

    cubalaya Overrun With Chickens

    2,722
    122
    266
    Nov 19, 2008
    central virginia
    it took me 3 years to get better than a 70% hatch but finally got a 100% last hatch. i will not adjust temp again and i know now how much humidity i need
     
  3. spish

    spish De Regenboog Kippetjes

    1,847
    12
    173
    Apr 7, 2010
    Belgium
    hi, sorry, i didnt ask about temps or humidity but thanks for the reply....i was wondering if i can use the machine without the foam pads/metal bar in the bottom? thanks
     

BackYard Chickens is proudly sponsored by