Brinsea octogon question

Discussion in 'Incubating & Hatching Eggs' started by pbzmomma, Sep 12, 2011.

  1. pbzmomma

    pbzmomma Out Of The Brooder

    52
    0
    39
    Aug 30, 2011
    Virginia
    Hi guys I bought this incubator recently and i have a question about the autoturner. when i put the incubato in the thing it is at a very steep angle and it does not seem to be working. Also the water just leaks out of the trays in the bottom due to the angle. am I doing something wrong or is it supposed to be like that. Its very annoying!
     
  2. blefky

    blefky life in the yard

    878
    6
    131
    Mar 18, 2010
    stamford, ct
    The turner moves very slowly - have you given it enough time to see if it really isn't turning? If water is leaking due to the angle of the incubator, you have the reservoirs filled too high. The "full" point in the reservoirs is probably not much more than half way up. I love my Brinsea, I've gotten some very nice hatches with it. Good luck with your hatch. [​IMG]
     
    Last edited: Sep 12, 2011
  3. pbzmomma

    pbzmomma Out Of The Brooder

    52
    0
    39
    Aug 30, 2011
    Virginia
    I have been manually turning. I didnt want ot risk the auutoturner and I had it running for 2 days before i put the eggs in there and it was always at the same angle. THank you
     
  4. dmazaika

    dmazaika Out Of The Brooder

    17
    0
    22
    Sep 7, 2011
    Concord
    Only fill the resevoir up half way. The autoturner is slow so check after 1-2 hours.
     
  5. jcatblum

    jcatblum Chillin' With My Peeps

    2,548
    20
    173
    Oct 27, 2010
    Cement, OK
    Make sure it sitting on the cradle correctly. Mine wasn't "snapped" all the way down & I had a problem once. After you get it working you will love it!! Only problem with mine is it is always full of eggs!
     

BackYard Chickens is proudly sponsored by