DARN! Woke up this morning and my temp was 96.6°F :(

Discussion in 'Incubating & Hatching Eggs' started by CheekyMare, Nov 20, 2011.

  1. CheekyMare

    CheekyMare Chillin' With My Peeps

    I took the turner out last night, added some water, turned the temp down a titch as it was 101, and went to bed. Should have stayed up to watch. [​IMG]

    I also put a small crack in one egg through carelessness but it was just above the membrane so I wasn't panicking about that.

    *kicks self*
     
  2. Ukiah

    Ukiah Chillin' With My Peeps

    413
    0
    89
    Nov 15, 2011
    AL
    Hey, 96.6 isn't THAT bad [​IMG]
    You may have a bit of a late hatch, if anything. Cool temperatures slow development.
    Once I had my incubator go from 100F to 107F [​IMG] I was freaking out, but had OK
    hatches. Obviously it didn't stay high to long, haha. Hope your hatch goes well [​IMG]
     
  3. GrannysRoost

    GrannysRoost Chillin' With My Peeps

    650
    0
    111
    May 4, 2011
    Casa Grande
    They should be fine as that big they should be putting off some heat on their own! People have power outages and they hatched, I had my AC go out last summer and had to put ice in the bottom to cool down! Just locked my crew down a bit ago....here goes staring at the bator [​IMG]
     
  4. ChickenCanoe

    ChickenCanoe True BYC Addict

    22,048
    3,092
    506
    Nov 23, 2010
    St. Louis, MO
    Quote:X2
    temporarily too cool beats too hot.
     
  5. jeslewmazer

    jeslewmazer Chillin' With My Peeps

    Nov 24, 2009
    Mississippi
    Have you covered the crack? Unless they are hatching a crack can kill. How far along are they?
     
  6. CheekyMare

    CheekyMare Chillin' With My Peeps

    I didn't cover the crack as it's up in the airspace and they should be pipping into that today anyway. I figured doing nothing was better than making it worse. Day 21 is Tues/Wed.

    I'm going down to see if the temp is staying stable.

    .....never did post this as the server was down.

    5 hours later:

    I did go down and the temp seems stable. I took out the egg with the lowest chance of hatching(the cracked one) and candled. Saw the chick moving in the shell but no internal pip yet so I'll just watch and wait now.
     
  7. Dbc

    Dbc Chillin' With My Peeps

    132
    3
    91
    Jun 3, 2011
    I had a lower outage tho week and I still had my chicks hatch!
     
  8. jeslewmazer

    jeslewmazer Chillin' With My Peeps

    Nov 24, 2009
    Mississippi
    That one should be ok if it is fixing to hatch.
     
  9. kenny7673

    kenny7673 Out Of The Brooder

    28
    0
    22
    Nov 13, 2011
    hillsboro
    Quote:hearing that makes me feel a lil better. My incubator goes from 100 to about 103. i was getting worried that 103 would be to hot.[​IMG]
     
  10. billiejo21

    billiejo21 Chillin' With My Peeps

    289
    0
    89
    Oct 16, 2011
    Iowa
    Figured out after my last hatch that my thermometer in my hatching bator was 3 degrees off rather than the 1 I had originally thought [​IMG] ...my eggs spent there last couple of days around 97.5...I had all 8 hatch, 1-2 days late, but they all made it!! Good luck!
     

BackYard Chickens is proudly sponsored by