Dry Hatching in a Brinsea Octagon 20 Advance

Discussion in 'Incubating & Hatching Eggs' started by MichenerFarm, Feb 15, 2013.

  1. MichenerFarm

    MichenerFarm Out Of The Brooder

    52
    0
    39
    Apr 13, 2011
    The Wild West
    Have any of you had a successful dry hatch in a Brinsea Octagon 20 Advance? If so, what exactly did you do? If not, what did you do? LOL! I appreciate any & all feedback! [​IMG]
     
  2. Pancholoco

    Pancholoco Chillin' With My Peeps

    483
    18
    103
    Nov 12, 2012
    Sin, MX. now CA.
    I went with dry hatch, humidity is high 30% no water added, let's see what happens. Set on Feb 13TH, lockdown @ March 4TH and Hatch day March 6TH
     
  3. gnvawms

    gnvawms Out Of The Brooder

    13
    0
    22
    Feb 22, 2013
    Grenada, MS
    How did this work for you? I've just recently purchased an Octagon 20 Advance and I haven't set any eggs yet as I can't decide to go with a wet or dry hatch. What was your hatch rate with dry hatch?
     
  4. Pancholoco

    Pancholoco Chillin' With My Peeps

    483
    18
    103
    Nov 12, 2012
    Sin, MX. now CA.
    15 from 17, the last 2 eggs were undeveloped embryos.
     
  5. gnvawms

    gnvawms Out Of The Brooder

    13
    0
    22
    Feb 22, 2013
    Grenada, MS
    Awesome! So did you keep it around 30% humidity the entire time? And what was your humidity during lockdown?
     
  6. Pancholoco

    Pancholoco Chillin' With My Peeps

    483
    18
    103
    Nov 12, 2012
    Sin, MX. now CA.
    First 18 days between 30 and 35%, lockdown 70-80%, this time I'll increase humidity at 15 day, last time I had to help 3 eggs they pipped but never did they alone.
     
  7. annabell254

    annabell254 Chillin' With My Peeps

    471
    6
    93
    May 21, 2012
    south Ga
    I just got my brinsea 20 advanced and hatched my first set of eggs... I kept it at about 45% humidity.... none of my chicks could zip after piping... and ALL had to be assisted... they were too big.... and they ALL hatched late!!!

    factory set at 99.6 and I will up it to 99.8 for this next batch
    humidity will be at 35% and I will weigh them so I know if I need to up it or lower it
    I will up it to 60% at day 18 and then 80% after I hear my first pip


    ANYONE else have problems with late hatches or too big of chicks with the factory settings????
     
  8. Pancholoco

    Pancholoco Chillin' With My Peeps

    483
    18
    103
    Nov 12, 2012
    Sin, MX. now CA.
    That happened to me at my first batch, temp was 99.5 humidity first 18 days was 40-55% and 70+ at lockdown I assisted almost all of them... Of course they hatched late too got my last pip at day 23 that was hard. And at my second batch I went to 99.8˚ last hatch and all was ok,I use dry hatch, humidity 25-35% for first 14 days and 50-55% day 15-17 and 70% + at lockdown all hatched.
     
    Last edited: Apr 9, 2013
  9. annabell254

    annabell254 Chillin' With My Peeps

    471
    6
    93
    May 21, 2012
    south Ga
    GREAT TO KNOW!!!!!!! I just got my 2nd set of eggs today.... uped my temp to 99.8.... but was still a little worried.... good to know your next hatch went better! This time was crazy for me!!!!
    With that temp and humidity, did they hatch by themselves and on time?
     
  10. Pancholoco

    Pancholoco Chillin' With My Peeps

    483
    18
    103
    Nov 12, 2012
    Sin, MX. now CA.
    Yes, they did it. All hatched on day 21 in less than 24 hours. Good luck with yours.
     

BackYard Chickens is proudly sponsored by