Grandbuttons THEY HATCH!! * I FEEL SO STUPID!!!! * UPDATE!

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
Well today i take my 6 *test* button quail eggs off the turner..these eggs are from my own button quails...i wanted to see if they were fertile

Witch i think they are!


the other day when i open the bator to add some water i pick up each egg and i could have swore i felt movement in each one


I don't want to get my hopes all up because these are test eggs and i have to keep reminding myself that but it would be nice to get some Grandbuttons out of all this



So like always i will update on here and if all goes well there will be LOTS of pics to share with you all
so wish me luck.
 
Last edited:

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
****UPDATE****


Well the button eggs are off the turners

but i am having the HARDEST time keeping my humidity down.. i don't have hardly any water in the bator and the humidity keeps going pass 80%

so i took both red plugs off the top to vent more and i'm waiting now to see if it goes back down







************************************

OK i had no choice .. i took all the water out the bator and replace it with a damp cloth.. for some reason the humidity will not go down for anything..when i went to go recheck it was reading HI so that 100%

so out with the water
 
Last edited:

77horses

◊The Spontaneous Pullet!◊
11 Years
Aug 19, 2008
7,531
539
396
Maine
That's great! I hope you get loads of babies!


To help make humidity go down, sometimes you can open the bator a tiny tiny bit, making sure that the temp. doesn't drop too low. Then you wait til hum. goes down a bit.
Another thing you can do is if the bator has precipitation on the walls, wipe it off with a paper towel. This will help some.



I hope it all works out fine! Good luck!
 

Mrs MIA

Chick Magnet
11 Years
Mar 3, 2008
7,988
58
303
You did the right thing, but after this hatch I would check your thermomter/hygrometer. It may have gotten wet. Keep us posted!
 

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
Thanks


but now i think my bator is acting up.. it wont make the temps go up .. i turn the thingy twice already and the temps still wont go up...there staying at 94.5
 

Mrs MIA

Chick Magnet
11 Years
Mar 3, 2008
7,988
58
303
When my thermometer got wet inside, it was reading low, too. Do you have another one that you can put in there?
 

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
Yea i just put it in there about 10mins ago and the humidity is reading 67% but the temps are reading 95.0 i don't know why my temps wont go up
 

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
I don't know why my bator is not working right.. i can turn the knob 50 times and the temp wont go up so i open the bator for one last time and i elevated the eggs high enough to reach a temp of 99.5 witch they are now so i just hope if there are any chicks in the eggs that they didn't die from all the bator problems this morning
 
Last edited:

Mrs MIA

Chick Magnet
11 Years
Mar 3, 2008
7,988
58
303


What kind of incubator/heating element are you using? Could the wafer have burnt out? Or the heating element gone bad? Knob broken?
 

BirdBoy88

Angel Egg
12 Years
Dec 26, 2007
3,508
8
221
Maryland
I have 2 LG bators and they have been working GREAT for me up to this point.. one LG is only a year old and has only been used 5 times and my other LG is only 1 month old and only been used once and on both the temps wont go pass 99.5 when the racks are in and once the racks are out they wont go pass 95.0

i may have to get my dad to check them out because i'm blank
 

New posts New threads Active threads

Top Bottom