Heating Element in LG incubator stopped

Discussion in 'Incubating & Hatching Eggs' started by Jharper, Nov 19, 2013.

  1. Jharper

    Jharper Chillin' With My Peeps

    3,730
    82
    193
    Oct 20, 2012
    Tifton, Ga
    Okay, so I got my Newest edition LG incubator set up so I could put some duck eggs in today, but I woke up to it have stopped working. The air fan works perfectly fine, but the heating element does not. I've unscrewed it from the top and everything to try and get it to work again but nothing has happened. I got a little red flicker out of the light, heating element is warming up sign, and then it just quit. What's wrong with it???? Help please!!!!
     
  2. Bill 101

    Bill 101 Chillin' With My Peeps

    385
    20
    90
    Feb 1, 2013
    Oregon
    I know this is a dumb question, but did you try adjusting the thermostat ???
     
  3. Jharper

    Jharper Chillin' With My Peeps

    3,730
    82
    193
    Oct 20, 2012
    Tifton, Ga
    Yes. It's lose, if I press down on the the red light indicater it will cut on. I think there's something lose in it.
     
  4. Bill 101

    Bill 101 Chillin' With My Peeps

    385
    20
    90
    Feb 1, 2013
    Oregon
    It does sound like there is a short somewhere. If you can see the wiring, start moving wires & see if you can determine which wire is loose & then figure out how to tighten it ----- Only thing I can suggest
     
  5. Jharper

    Jharper Chillin' With My Peeps

    3,730
    82
    193
    Oct 20, 2012
    Tifton, Ga
    I've taken it apart but not plug in. I guess I will have to-to see what lose.
     

BackYard Chickens is proudly sponsored by