Help needed fixing incubator please

Discussion in 'Incubating & Hatching Eggs' started by mrslb333, Jan 15, 2011.

  1. mrslb333

    mrslb333 Chillin' With My Peeps

    923
    3
    123
    Jun 15, 2010
    Halifax, Nova Scotia
    Hiya, I need help fixing my Covatutto 120 incubator. [​IMG]
    It was running perfectly keeping temp perfect, I did have it running constantly for approx 12 weeks not sure if that could do damage? I came down one morning and it was smoking, the temp had soared to 130 and the water trays were melted and all the eggs cooked.
    I've started it up but the fan blows cold and it doesn't heat up. Could it just be the heating element thats blown?
     
  2. Mahonri

    Mahonri Urban Desert Chicken Enthusiast Premium Member

    30,361
    151
    446
    May 14, 2008
    North Phoenix
    My Coop
    I don't think I've ever seen that incubator on this side of the pond, but I imagine you'll probably need a new heating element and perhaps a new thermostat also.
     
  3. GreenGoddess

    GreenGoddess Chillin' With My Peeps

    Jun 6, 2009
    St Pauls, NC
    I agree... The thermostate could have gone out in turn causing the heating element to overheat and malfunction... Try replacing both of those and see if it does the trick!

    Goddess [​IMG]
     
  4. midget_farms

    midget_farms Chillin' With My Peeps

    Apr 15, 2008
    Dunlap Illinois
    X2 - sounds like the thermo didnt turn off the heat.
     
  5. mrslb333

    mrslb333 Chillin' With My Peeps

    923
    3
    123
    Jun 15, 2010
    Halifax, Nova Scotia
    This sounds expensive lol. Thanks for your help [​IMG]
     
  6. GreenGoddess

    GreenGoddess Chillin' With My Peeps

    Jun 6, 2009
    St Pauls, NC

BackYard Chickens is proudly sponsored by