hovabator 1588

Discussion in 'Incubating & Hatching Eggs' started by hen_house, Jul 25, 2011.

  1. hen_house

    hen_house Out Of The Brooder

    14
    0
    22
    Jul 25, 2011
    first time using this hovabator and with 2 thermostats inside temp looks to running at 98.2 and staying there, what numbers should i have up or down to get it where i need to be at, thanks well in advance
     
  2. Flawedatdesign

    Flawedatdesign Chillin' With My Peeps

    469
    0
    99
    May 18, 2011
    Dixon Missouri
    Well first off I want to say [​IMG] I'm a DIY incubator person but I'm sure somone will come along and help you out soon.
     
  3. Black Cochin Bantams

    Black Cochin Bantams Chillin' With My Peeps

    1,860
    99
    198
    Feb 24, 2010
    Iowa
    I would not adjust anything on it yet. How long have you had it running? I never adjust temperature within the 1st 2 days unless it running too hot. Unless you can calibrate or verify the thermometers accuracy I would go with the factory settings on a 1588 Genesis. Mine has hatched well right out of the box.
     
  4. cmom

    cmom Hilltop Farm

    16,199
    642
    396
    Nov 18, 2007
    Florida
    My Coop
    [​IMG] I agree let it set for a day or two. The temp should be 99.5. Also is it is a room with AC? I put my incubator in a room with no AC and the temp was fine but when I had it in a room with AC the temp fluctuated more.
     
    Last edited: Jul 25, 2011

BackYard Chickens is proudly sponsored by