Hovabator 1590 died

Discussion in 'Incubating & Hatching Eggs' started by CindyS, Jul 16, 2008.

  1. CindyS

    CindyS Songster

    666
    5
    151
    Apr 14, 2008
    Geneseo, Illinois
    One of my hovabators died and its one of those preset 1590 models -before they were genesis. The fan runs but no heat. What went bad on it so I can replace it. Can they be fixed? I suppose I wore it out. Its been running non stop since November. Anyone know anything about fixing these things?
     
  2. ozark hen

    ozark hen Living My Dream

    6,962
    27
    291
    Apr 4, 2007
    Mansfield, MO
    sorry, the only thing I can tell you is to do a search and check out Miss Prissy's homemade incubator. Lots of folks have made their own. good luck
     
  3. homeandbarnbasics

    homeandbarnbasics In the Brooder

    75
    0
    29
    Jun 29, 2008
    Tallassee, AL
    I called GQF to see if I could get another thermostat for you and they said that they don't make it and that they don't have anymore available. I asked about retrofitting it with the thermostat out of the 1588 and they said that it would not work with the heating element in your bator. I have not personally tried it so I can't personally say one way or the other. Sorry I couldn't help.

    Tony
     
  4. Katy

    Katy Flock Mistress

    Is your heating element heating up? I got a replacement heating element for my 1590 last winter from GQF.
     
  5. clhnd

    clhnd Hatching

    4
    0
    7
    Feb 5, 2012
    never had a problem with my 1590 models. i have hatched atleast 50 loads of eggs in each one. the 1588 is even better.
    but no complants with my 1590 models. would love to buy as many 1590 models that i can get my hands on.
     

BackYard Chickens is proudly sponsored by: