Humidity and temperature not working!!!

Discussion in 'Incubating & Hatching Eggs' started by PulletSurprise, Jun 3, 2008.

  1. PulletSurprise

    PulletSurprise Chillin' With My Peeps

    121
    0
    129
    May 9, 2008
    Salem OR
    I'm so mad!!! :thun [​IMG] [​IMG] I'm on the last 3 days of hatching. I took out the top 2 plugs, like it's been said. Before going to bed, I had the temperature right and the humidity I was struggling with. I get up 8hrs later; I'm up to 105 degrees and 55% humidity!!!!! [​IMG] I have a bowl of water AND a sponge in there trying to get the humidity back up, I closed up both vents and decided if they need air then I will physically blow air into it through one of those stupid vents. [​IMG] My humidity is now up to 72% when I last looked and my temp is doing whatever it wants to I guess for the moment. I couldn't get the temp to go down for the first 30mins, so I unplugged it when I closed up the vents and the temp came down. So, it's plugged back in, but I need to go and see what the temp is now. Living in Salem Oregon, should the humidity be at 75-80% or up to 85%?? If anyone has any advise, please send some my way. This is my first hatch and I had atleast 2 live babies out of 15 eggs as of yesterday when day 18 started. [​IMG]
     
  2. PulletSurprise

    PulletSurprise Chillin' With My Peeps

    121
    0
    129
    May 9, 2008
    Salem OR
    Oh let me give a quick update....I'm back up to 105 degrees and the humidity is down to 65% [​IMG] What is going on??!! The little red light on the Incubator, LG still air, is flashing and then stops, when I turn down the temperature it doesn't go off, it stays red. What is going on here?!! I don't think I'm meant to hatch eggs. [​IMG]
     
  3. Homegroanacres

    Homegroanacres Chillin w/the Ice in my Glass

    409
    0
    139
    Apr 10, 2008
    Salem, Oregon
    I have noticed a varying range on my humidity also, which seem
    to change due to the outside humidity, but it has never gone outside
    the range of what I would concider normal. However I am on day
    12 so that may not be the same as I will find on day 18.

    As for the temps, (I am no expert here) but did you put in a
    shelf linner? that may bring the temps up due to it holding heat.

    The unborn chicks (a more solid mass) could bring up the temps
    also (I would think but then again I am no expert)

    Maybe move the bator to a colder room for these last few days

    Turn the thermostat down and leave it, it would seem to me that
    it will take a longer period of time for the temp to moderate than it
    would for a forced air. I suppose it is within reason to think the
    themostat (wafer) has gone bad.

    Wish I had a perfect answer for you [​IMG]

    John
     
  4. PulletSurprise

    PulletSurprise Chillin' With My Peeps

    121
    0
    129
    May 9, 2008
    Salem OR
    No shelf liner, but I did add a styrofoam egg container. My bator will not regulate. I have the temperature gauge turned all the way down but the red light stays lit. it's not regulating itself and it's brand new. I have 2 bators going with the same thermostat/hygrometer and I added the other one to double check and it was reading the same. I didn't open the lid per say, I opened one of the little plastic windows and set it in and took it out.
     
  5. Homegroanacres

    Homegroanacres Chillin w/the Ice in my Glass

    409
    0
    139
    Apr 10, 2008
    Salem, Oregon
    About the only thing I would try (since to high mean loss of chicks)
    would be to lower the temp by proping the top open a bit and adding
    more water to keep hum up. Can't be any worse than frying them and
    at least you have tried [​IMG]

    When you do that the lite will stay on of course

    Sorry I don't have more ideas

    John
     
  6. Eggseronious

    Eggseronious Chillin' With My Peeps

    621
    1
    151
    Mar 6, 2008
    East Tennessee
    I had the same thing happen yesterday afternoon, and it liked to drove me crazy adjusting temperature, moving thermometers and so on. I got things pretty close and noticed one little pip. Got up this morning and 2 chicks now I have 4 man these fellers are active like something wild, they are Dominiques. I think they were creating heat themselves late yesterday, causing my temp spikes. [​IMG]
     
    Last edited: Jun 3, 2008
  7. PulletSurprise

    PulletSurprise Chillin' With My Peeps

    121
    0
    129
    May 9, 2008
    Salem OR
    Sheesh..nothing is working. I took out the egg carton and it felt like room temp. What more harm can be done? The incubator still wont turn off unless I unplug it, humidity only rises when I add a warm sponge. I have my 2nd bator full of eggs. I'm dreading that now. After this, next year it's all done the natural way. I will never do this again. I feel like I'm killing these things and it's just not right. It's one thing for nature to do it, but it's another when you are doing it and using "man-made" products.
     
  8. Eggseronious

    Eggseronious Chillin' With My Peeps

    621
    1
    151
    Mar 6, 2008
    East Tennessee
    What brand and type of incubator do U have?
     
  9. PulletSurprise

    PulletSurprise Chillin' With My Peeps

    121
    0
    129
    May 9, 2008
    Salem OR
    Little Giant still air :|
     
  10. Eggseronious

    Eggseronious Chillin' With My Peeps

    621
    1
    151
    Mar 6, 2008
    East Tennessee
    I dont know about the L Giant, but I sent Miss Prissy a pm to have her to see if she can help.
     

BackYard Chickens is proudly sponsored by