I know why your 1588 makes that loud noise

Discussion in 'Incubating & Hatching Eggs' started by KYBOY, Apr 1, 2009.

  1. KYBOY

    KYBOY Chillin' With My Peeps

    468
    16
    161
    Mar 8, 2008
    Eastern,Kentucky
    One of mine started to do the same. I knew it was the fan but wasnt sure of the cause..I called cutlers and they had GQF send me a new fan sice the incubator was only two months old (great customer service by the way [​IMG] )..Anyway when I disassembled the fan/heating unit to install the new fan I found the problem...Even though the fan still "works" it has slipped down the drive shaft that turns the fan..When it slips down to the end of the drive shaft it then makes that loud "dental drill" sound folks mention..Just thought I would pass it along..
     
  2. TaLani

    TaLani ~ Gemini Chick ~

    Oct 2, 2008
    Bryson City, NC
    Oh my gosh, mine does this too! Right out of the box it did it! So, you can't really fix it per se, you have to get a new fan, correct? Did u have to pay for the new fan? That's one complaint that I have for my new 1588, is the LOUD whining noise. I just thought it was normal. Glad u posted re this, thanks! [​IMG]
     
  3. KYBOY

    KYBOY Chillin' With My Peeps

    468
    16
    161
    Mar 8, 2008
    Eastern,Kentucky
    Mine was still under warrenty so they replaced it after i told them it stopped working correctly.Though mine didnt just whine it vibrated too.The fan still circulated per say but screamed like a banshee [​IMG] When I took the fan out I could push on the fan blade assembly and it would move up and down about 3/16th of an inch..
     
    Last edited: Apr 1, 2009
  4. chickabator

    chickabator Chillin' With My Peeps

    Nov 30, 2007
    ky
    I hope mine don't do that I just got a 1502 and a 1550 so far everything is going alright
     

BackYard Chickens is proudly sponsored by