Incubator Help Please

Discussion in 'Incubating & Hatching Eggs' started by cbabcock5, Mar 6, 2012.

  1. cbabcock5

    cbabcock5 Out Of The Brooder

    28
    0
    22
    Feb 15, 2012
    I just bought a second incubator (farm innovators pro) and plugged it in and even with it on its lowest setting the temp was 106 and climbing. This can not be right, right? I used about 6 thermometers lol because i wasn't believe the first 3, should i just take it back to the store or let it sit and see if it will settle down? any advice would be very appreciated.
    Thanks
     
  2. mustangsaguaro

    mustangsaguaro Chillin' With My Peeps

    684
    5
    161
    Nov 30, 2007
    San Martin, Ca
    How long have you had the incubator plugged in. When I plug my incubator in I will usually let it sit for 24hrs before fiddling w/ the temps. If I need to adjust it to go down I will usually adjust go back in maybe 4-5 hrs and readjust if necessary. It might take you a good 48hrs to get it to the temp needed. I use a water weasel and a digital thermometer w/ a probe on it and stick the probe in to the center of the water weasel and then get it as close to 99.5 degrees. This mimics the inside temp of the egg you want. Some time it will go up or down a 1/2 degree. I'm not to worried about the 1/2 degree change in temp. If you use this method of using the water weasel it doesn't matter if you have a still air or forced air bator. You want the actual temp of inside the egg. Hope this info helps.
     
  3. cbabcock5

    cbabcock5 Out Of The Brooder

    28
    0
    22
    Feb 15, 2012
    I had it plugged in for about 5 hours and set on the lowest setting and it would not get lower than 106. i don't have a water weasel it just worried me that the heater was messed up if it wont go lower than 106
     
  4. zookeeper15133

    zookeeper15133 Chillin' With My Peeps

    789
    6
    123
    Apr 22, 2010
    SW PA
    Is it sitting in front of a sunny window or heat vent, or on top of something that generates heat ( fridge, TV, cable box etc)?
     
  5. cbabcock5

    cbabcock5 Out Of The Brooder

    28
    0
    22
    Feb 15, 2012
    nope not near anything that produces heat, and was actually in a fairly cool room. my husband took it back to the store and got another LG
     
  6. mohillbilly

    mohillbilly Chillin' With My Peeps

    471
    15
    101
    Jan 15, 2012
    Poplar Bluff , MO
    it probably had a faulty thermostat ...it happens
     

BackYard Chickens is proudly sponsored by