LG 10300 is trash please help!

Discussion in 'Incubating & Hatching Eggs' started by geecia1135, Feb 20, 2019.

  1. geecia1135

    geecia1135 In the Brooder

    13
    2
    14
    Feb 18, 2019
    Northern California
    Please help I bought this little giant 10300 and I can’t seem to get an accurate reading I posted a few days ago and got good advice but I’m still dealing with the same problem, I’ve had it running for 5 days already. I lowered the temp on the built in therm because the first 2 therms I bought were much higher so I tried stablizing them to 99.5 I went and bought a digital hydro thermometer and it’s giving another reading. Also humidity is high and both are at different % just took some water out to see what happens.
     

    Attached Files:

    Last edited: Feb 20, 2019
  2. Rammy

    Rammy Crowing

    1,103
    685
    307
    Oct 20, 2008
    Tennessee
    Can you take it back?
     
    ButtonquailGirl14 likes this.
  3. geecia1135

    geecia1135 In the Brooder

    13
    2
    14
    Feb 18, 2019
    Northern California
    No unfortunately I can’t :/
     
    ButtonquailGirl14 likes this.
  4. Rammy

    Rammy Crowing

    1,103
    685
    307
    Oct 20, 2008
    Tennessee
    Darn. :(
     
    ButtonquailGirl14 likes this.
  5. GotCoop

    GotCoop Songster

    202
    505
    182
    Jan 10, 2013
    Baker, Fl
    Is it just the humidity that's the problem, or both temp and humidity?
     
    ButtonquailGirl14 likes this.
  6. geecia1135

    geecia1135 In the Brooder

    13
    2
    14
    Feb 18, 2019
    Northern California
    It’s both temp and humidity:/ I’m giving up I’ve been running it for days
     
    ButtonquailGirl14 likes this.

BackYard Chickens is proudly sponsored by: