Lost hatch....

Discussion in 'Incubating & Hatching Eggs' started by chicksnducks, Jan 25, 2008.

  1. chicksnducks

    chicksnducks Chillin' With My Peeps

    236
    0
    139
    Apr 16, 2007
    Durant OK
    Seems that this hatch was not meant to be ....started with problems with turner..again....(last one hatched ok) then when I candled on day 10 they didn't quite look right..but .....yesterday when I went to take them out of turner bator was at 75...seems that the big flashlight rolled onto the power strip and turned it off![​IMG]
    so I candled again and they were all clear or had a bacterial ring...
    so I am thinking maybe since I enlarged their pen that maybe the Roo's were having trouble catching the hens.....
    and now I only have my silkie roo...(and two banties) ...I think I need a grown up roo.....
    My next bator batch is going to be ducks!!![​IMG]
    well guess I just needed to vent...at least I didn't cry![​IMG]
    any ideas?
     
  2. Tuffoldhen

    Tuffoldhen Flock Mistress

    7,505
    19
    301
    Jan 30, 2007
    WV
    Sorry to hear about this hatch...Don't give up and work thru the problems...Last hatch of shipped eggs I got, none even developed....hatched my own with 100%...
     
  3. Pinenot

    Pinenot Chillin' With My Peeps

    754
    1
    151
    Sep 11, 2007
    If they had a blood ring...then it didn't matter what you did or didn't do, they were not going to make it. Clean your bator with anti-bacterial soap, set it in the sun for a day and start over. It will be better next time. Don't give up [​IMG]
     
  4. AussieSharon

    AussieSharon Chillin' With My Peeps

    Dec 18, 2007
    Virginia
    so sorry, good luck for your next hatch
     

BackYard Chickens is proudly sponsored by