Need incubator help !!!

Discussion in 'Incubating & Hatching Eggs' started by GeoGreyWolf, Jan 15, 2018.

  1. GeoGreyWolf

    GeoGreyWolf Songster

    385
    412
    111
    Sep 21, 2017
    Florida
    So while in my garage helping a friend, my almost 2 year old comes out and hits buttons on the incubator and turns it off.. i turn it back on, it starts to rise back up temp wise so figured all was well.. I go to check on everything this morning (going on day 2) and the incubator is showing temps in the 70's instead of 100 that I had it for. Went to try and set the temp back to normal like i did when i set it up, and get some weird negative one number. Tried google, reading up, looked at printed manual for this incubator and no luck. I can not seem to fix the issue, does anyone have any advise or know how? Incubator is Janoel 48. I got it from ebay, and was working in test run and all, now if i cant get it working in out $80 and the 6 eggs in it being incubated.
    IMG_4477[1].JPG
     
  2. ChickenCanoe

    ChickenCanoe Free Ranging

    26,008
    10,723
    727
    Nov 23, 2010
    St. Louis, MO
  3. GeoGreyWolf

    GeoGreyWolf Songster

    385
    412
    111
    Sep 21, 2017
    Florida
    i will try, i heard this early in incubation since day 0 & 1 were normal for the most part it could kill them? hopefully if i can get it to work again it wont be the case
     
  4. ChickenCanoe

    ChickenCanoe Free Ranging

    26,008
    10,723
    727
    Nov 23, 2010
    St. Louis, MO
    A quick cool down early in incubation shouldn't be a problem. The details are in the link I posted.
     
  5. GeoGreyWolf

    GeoGreyWolf Songster

    385
    412
    111
    Sep 21, 2017
    Florida
    I might of figured out finally what happened. Some how she might of messed with the factory settings? which shut off the heating element or kept it really low. I am testing it out now to see if it goes back up, wish me luck. No idea how she could of done it since it took me all day to figure out how to fix it back to factory setting on the temps
     
    ChickNanny13 and Laodicia like this.
  6. Chicken man15

    Chicken man15 Chirping

    42
    3
    54
    Jan 20, 2015
    It’s possible that she might have tweeked the calibrations. For temp and humidity
     
  7. GeoGreyWolf

    GeoGreyWolf Songster

    385
    412
    111
    Sep 21, 2017
    Florida
    not sure how she did it in the short time frame she was at it. but some how she did that. I managed after alot of looking and playing with it, get the temp settings back to the factory settings.. Now the temp is staying at a constant 99, better than the 70. Will try and tweek to get to the 100-101 mark i want. With the 99, i believe my ducks can still hatch hopefully might just take an extra day?
     
  8. Chicken Whisper101

    Chicken Whisper101 Songster

    154
    319
    101
    Jan 14, 2018
    Monks Corner SC
    Not good turn it off and turn it back on.
     
  9. HereChickChickChick88

    HereChickChickChick88 Songster

    104
    107
    113
    Jul 12, 2017
    Wait, so there's a day 0? I probably just screwed up some eggs. I put my eggs in the incubator on a friday after lunch so counted from then till sat after lunch as 1 full day, then after lunch on sat was the beginning of day 2. Goodluck to you on your hatch and incubator.
     
  10. GeoGreyWolf

    GeoGreyWolf Songster

    385
    412
    111
    Sep 21, 2017
    Florida
    thank you, yeah the first day (day you set them) is day 0, after that it goes day 1 through whatever type your eggs hatching are... this is what i have seen others post on here and reading some articles here and there
     
    HereChickChickChick88 likes this.

BackYard Chickens is proudly sponsored by: