Not a single egg developed

Discussion in 'Incubating & Hatching Eggs' started by conny63malies, May 8, 2008.

  1. conny63malies

    conny63malies Overrun With Chickens

    5,189
    51
    288
    Mar 22, 2008
    Annetta Kentucky
    [​IMG] I received 15 EE eggs two weeks ago. Not a single one was broke so i set them that day at midnight. After few day i candeled-nothing. But i figured give it a few more days, as i only have a crank flashlight and the shells were green. Fastforward 4 days. Again nothing- i deceided to open a egg that i was confidend was empty. I found a bulls eye , but that was it. Now at day 14 i took all the clear ones out and only kept the 3 in that are so dark that i cant see in.
    What can cause a total wipeout ?
    There were two with the air pocket knocked loose, thats it. could it have been the USPS x-raying?
     
  2. living2ride

    living2ride Chillin' With My Peeps

    179
    1
    131
    Feb 17, 2008
    Illinois
    The same thing happened to me with a batch of Cuckoo Marans. I put in two of my own eggs as a control group, and one of those hatched fine. So I'm assuming the shipped Cuckoo eggs were x-rayed. [​IMG]
     
  3. conny63malies

    conny63malies Overrun With Chickens

    5,189
    51
    288
    Mar 22, 2008
    Annetta Kentucky
    I am sooo bummed over this. I wanted some EE's so bad. But i played it safe and ordered some WCBP and golden phoenix eggs from Leon Valley trading Company on ebay. I got my other eggs from there and trust them. They just dont have any EE's or ameraucanas. They should come today. Did your package have a don not x-ray ticker? mine only was marked "fresh eggs"
     

BackYard Chickens is proudly sponsored by