not again!!

Discussion in 'Incubating & Hatching Eggs' started by jj ranch, Feb 23, 2009.

  1. jj ranch

    jj ranch Chillin' With My Peeps

    141
    0
    119
    Jan 13, 2009
    i just checked temp said it was 100. it lied!!! [​IMG] they have been in there for 1 day. please tell me im ok. it was 10 degrees off. i put a digetal in there and it correcting as we speak. [​IMG]
     
  2. william9792

    william9792 Chillin' With My Peeps

    796
    1
    131
    Nov 23, 2008
    graham, nc
    i would leave them in there and candle them at day 7 and see what they look like, but it don't sound good to me (110 ?) most of the time they will be dead. sorry william
     
  3. rodriguezpoultry

    rodriguezpoultry Langshan Lover

    10,907
    74
    328
    Jan 4, 2009
    Claremore, OK
    How much higher could it have been?

    100*F is a good temp???
     
  4. jj ranch

    jj ranch Chillin' With My Peeps

    141
    0
    119
    Jan 13, 2009
    im sorry i wasnt clear, it was 90 and not 100 when it said it was 100
     
  5. rodriguezpoultry

    rodriguezpoultry Langshan Lover

    10,907
    74
    328
    Jan 4, 2009
    Claremore, OK
    OOHHH...well then your fine! They won't even START growing until you have a temp higher than 98*F!

    It'll just set the hatch back 1 day!
     
  6. william9792

    william9792 Chillin' With My Peeps

    796
    1
    131
    Nov 23, 2008
    graham, nc
    well you will be fine if it was just one day at 90 deg then they may take a day longer to hatch, i thought you said it was at 110 and you brung it down to 100, still candle at day 7 or ten just to make sure. good luck william
     

BackYard Chickens is proudly sponsored by