Not sure where to post this... incubator problem - HELP!

Discussion in 'Incubating & Hatching Eggs' started by Cherlyn, Aug 31, 2009.

  1. Cherlyn

    Cherlyn Chillin' With My Peeps

    917
    0
    139
    Feb 24, 2009
    Alconbury, England
    Just got the R-Com 20. Running fairly quietly for the last several days. Now it sounds... hard to explain. You know the sound when you turn on an electric razor? It makes that sound, for about five seconds, every five seconds or so. What is going on, or is that normal?

    ~Cherlyn
     
  2. Bleenie

    Bleenie Wyan-DO's

    it might be the turner if it has one of those in it? i know my turner makes funny noise sometimes.
     
  3. Cherlyn

    Cherlyn Chillin' With My Peeps

    917
    0
    139
    Feb 24, 2009
    Alconbury, England
    Quote:Hm... yes, it has a turner. It just turned the eggs a few minutes ago. I need to make sure my motor is not about to die or something - the 'bator is filled with eggs!

    ~Cherlyn
     
  4. Bleenie

    Bleenie Wyan-DO's

    i hadnt used mine in months and it make terrible noise when i started using it again, now it's a lot quieter and only does it sometimes. still turns they eggs though. it's really old so i wouldnt be suprised if my motor was going out. [​IMG]
     
  5. Cherlyn

    Cherlyn Chillin' With My Peeps

    917
    0
    139
    Feb 24, 2009
    Alconbury, England
    Anyone else? Sorry, but I am heading to bed very soon and am panicked at the idea of the motor giving out in the middle of the night! [​IMG]

    ~Cherlyn
     

BackYard Chickens is proudly sponsored by