PLEASE PLEASE HELP!

Discussion in 'Emergencies / Diseases / Injuries and Cures' started by AustralorpsAU, Sep 20, 2016.

  1. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    Can anybody help me. Today was the day i was going to put some eggs in my incubator and its broken i think. When i press the set for temperature it comes up with -0.1 and it wont change! Why? And when i press reset it doesn't reset the day? I'm so upset. Does anyone know why this is happening?
    [​IMG]
     
  2. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    Anybody?
     
    Last edited: Sep 23, 2016
  3. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    Temperature is just declining
     
  4. DwayneNLiz

    DwayneNLiz ...lost... Premium Member

    22,608
    8,146
    576
    Jun 18, 2013
    NH
    I don't know anything about that controller
    I think @Chaos18 uses it though
     
    Last edited: Sep 20, 2016
  5. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    ok thanks. Lets hope @Chaos18 comes soon
     
  6. Chaos18

    Chaos18 Minion King Premium Member

    31,796
    5,254
    536
    Mar 24, 2015
    Slowly Losing it......
    Sorry I don't know anything about that controller. What brand and model incubator?
     
  7. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    I'm guessing it's a Janoel 48 i think. It's what it looks like when i search it up
     
  8. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under
    I think the heating element is broken [​IMG]
     
  9. SirTerris

    SirTerris Out Of The Brooder

    35
    1
    24
    Dec 8, 2015
    i have the same unic, I think you need to hold + and - together for 6 seconds to reset the unit...it took me ages to figure out how to reset it a week ago when i started my hatch...

    hope that helps...but probably not...
     
  10. AustralorpsAU

    AustralorpsAU Chillin' With My Peeps

    1,247
    103
    141
    May 20, 2016
    Down Under

    Thank you sooooooo much it fixed it! Eggs have just gone in! Yaaaaaay
     

BackYard Chickens is proudly sponsored by