Two LG incubators quit working..

Discussion in 'Incubating & Hatching Eggs' started by txchickie, Sep 30, 2010.

  1. txchickie

    txchickie Chillin' With My Peeps

    Nov 15, 2008
    Texas
    I bought an LG incubator with the egg turner at TSC. (I had another LG but my 4 year old cracked the styrofoam). I bring home the incubator and get it set up....it heats up and runs for about 20 minutes and then quits. No heat, but the little light was still on.
    I take it back to TSC and exchange it (they were super good about it). Bring the new incubator home and get it set up. It runs for 8 hours at 100, perfect. I put my eggs in at 9am...go back to check it at 3pm and nothing. No heat, it won't do anything. The light won't even come on.

    What gives? [​IMG]
     
  2. BayouPoules

    BayouPoules Chillin' With My Peeps

    I don't know,.. but I'm getting rid of ours after this hatch( maybe junking it,.. don't want to pass on this bad deal I got),.. it keeps spiking when I'm not looking,.. if I stand there for an hour it's the same,..walk away for 30 minutes and Bam,.. it's 107 degrees! It's driving me nuts too,.. I hope you get yours going,..what else do they have at your TSC that you can afford?
    What did you do with the eggs?
     
  3. tracecom

    tracecom Chillin' With My Peeps

    344
    36
    151
    Jan 16, 2010
    If you still have all the pieces for the cracked LG, it can be easily fixed with styrofoam glue. I bought a 4 oz. bottle of "Foamtastic" at Hobby Lobby for $3.99. Works great.

    As to your current problem, check the obvious: make sure it's plugged in a live outlet and turned on. If that doesn't work, I'd take it back to TSC for a refund. LG's don't have good reputations.
     
  4. txchickie

    txchickie Chillin' With My Peeps

    Nov 15, 2008
    Texas
    I fed the eggs to my dogs. I'll collect more over the next few days (they're from my hens). My old one is pretty much crushed beyond repair....4 year olds can be destructive [​IMG]

    They don't carry any other incubators at TSC, so I will just take it back for a refund. Maybe try e-bay for a hovabator or something....I am just so irritated. The power is fine to that outlet, I even have it plugged in a surge protector to be sure.
     
  5. EweSheep

    EweSheep Flock Mistress

    21,917
    69
    418
    Jan 12, 2007
    Land of Lincoln
    All for the more reason I love my HOvabators, none of that LG junk! Either you hit the jackpot or not but the odds that LG is not very well manufactered or faulty somewhere down the assembly line.
     
  6. txchickie

    txchickie Chillin' With My Peeps

    Nov 15, 2008
    Texas
    Quote:I can get a hovabator on ebay for just a few bucks more, I'm definently going that route. I'm not wasting any more eggs on these new LG's.

    Funny thing is my old LG has lasted for YEARS. My grandma uses it constantly in the spring and summer hatching guinea eggs and I've used it several times myself.
     
  7. rebelcowboysnb

    rebelcowboysnb Confederate Money Farm

    If there still good then just put the guts of the old one in a cooler.
     
  8. EweSheep

    EweSheep Flock Mistress

    21,917
    69
    418
    Jan 12, 2007
    Land of Lincoln
    Well that would be worth a try! A friend of mine did that, installed a puter fan, and a different knob and she did ok. I got it from her and it runs OK but still having problems maintaining the heat. So it is for my hatching only, not incubating.
     

BackYard Chickens is proudly sponsored by