Umbilical /egg sac not fully absorbed. Hatch question

Redeagletrapping

Chirping
Apr 2, 2020
158
213
73
Upstate New York
Hello so I had a batch hatch yesterday and 18 of 22 made it initially but one was born prematurely probably from the others knocking it open. I had to cull that one tonight due to intestines sticking out and not able to get it in in time before drying.

I have a second one that had yolk sac attached and is active and mobile but covered in the sac. It dried up mostly and I ended up putting it in a water bath to soften and loosen everything.

The question is do I need to push in the umbilical back into the opening similar to a prolapse of the intestines or leave it alone. Pics below. It is clean and dry and I have given nutridrench. The umbilical looks mostly dry but I can see the opening.

Thoughts on leaving or closing up with glue.

Thanks for the help.
20200923_205732.jpg
20200923_205726.jpg
20200923_205723.jpg
20200923_205720.jpg
20200923_205702.jpg
20200923_205655.jpg
20200923_205732.jpg
20200923_205726.jpg
20200923_205723.jpg
20200923_205720.jpg
20200923_205702.jpg
20200923_205655.jpg
 

Redeagletrapping

Chirping
Apr 2, 2020
158
213
73
Upstate New York
So sorry for your loss, and sorry no one was able to reply sooner.
No worries sad for the little ones. And I posted late. I did bathe it and massage everything looked real healthy other than that one spot of umbilical cord.


Here's some pics of the rest , the 6 bigger ones came from my 1st batch 5 weeks ago I just put them out with my 10 week olds last night. I snuck them in the coop. Hoping they do well today lol. Always something.

20200923_201004.jpg
20200923_201000.jpg
20200923_170432.jpg
20200923_170427.jpg
20200923_170420.jpg
20200923_170415.jpg
 

New posts New threads Active threads

Top Bottom