What's wrong with my 'bator?

Discussion in 'Incubating & Hatching Eggs' started by nixzoo, Jan 12, 2015.

  1. nixzoo

    nixzoo Out Of The Brooder

    14
    0
    22
    Sep 17, 2012
    San Antonio, Texas
    About 2 years ago, I ran a Lyon (Marsh) Roll-X2 for the first time. It worked perfectly and incubated well. I had many chicks hatch. On the last batch, near hatching, it started making a loud noise and I think the temp was too low. The fan stopped moving also. I moved the eggs to a different incubator and they were ok. I thought it was the fan that had the problem. I'm planning on hatching more eggs this year so I want to fix it. I ordered a new fan, soldered the wires to it and hooked it up. It is making a noise like the fan wants to turn, but it doesn't.

    Is it the solid state thermostat that is bad? Does that make the fan work properly?
    I've looked all over, and can't find much except that the thermostat is most likely to fail. I don't want to leave it on long enough to see what temp it will get to since the fan may not do so well with that.

    Any advice? This is the first time I've tinkered with an incubator and so far I'm just guessing. I appreciate any advice, thanks.
     
  2. nixzoo

    nixzoo Out Of The Brooder

    14
    0
    22
    Sep 17, 2012
    San Antonio, Texas
    Anybody have any advice on fixing incubators?
     
  3. nixzoo

    nixzoo Out Of The Brooder

    14
    0
    22
    Sep 17, 2012
    San Antonio, Texas
    Is there somewhere else I can post/ask this question? Did I post in the wrong section?
     
  4. GAQuail

    GAQuail Chillin' With My Peeps

    295
    15
    111
    Jun 21, 2012
    Bishop, Georgia
    I have a couple of Roll-x incubators. An old marsh model and a newer solid state Lyon model. The thermostat does not control the fan. The fan should run at all times. If the fan won't run do not leave the incubator plugged in. As far as the noise and the fan not turning I have not experienced that. Are you sure you have the new fan wired correctly. I think I would call Lyon. You'll probably have to leave a message but a technician will call you back.
     
  5. nixzoo

    nixzoo Out Of The Brooder

    14
    0
    22
    Sep 17, 2012
    San Antonio, Texas
    Thanks, GAQuail.

    I purchased a new thermostat. I finally got it in the mail today. I hooked it up and it was the thermostat. With the new one, it runs like it is supposed to. My fan is connected to the thermostat circuit board with two different wires.

    I think the fan was actually fine, just the thermostat went bad.

    I have to figure out where all the washers go now. It's been so long since I took it apart, lol.
     

BackYard Chickens is proudly sponsored by