HELP! FIRST TIME! Different Temps??

Meplus3

Hatching
May 27, 2020
14
0
8
Someone please help! It's my first time incubating any eggs. I set up the new incubator, it only has temp reading on it not the humidity, anyhow I set it up to 37.5 and put the water in 1 slot as stated in the instructions then left it for 24 hours, next day we put in the eggs, and ordered an inside digital thermometer with humidity reader. We popped that in straight away and it's only reading 35.5 with a very high humidity!! I've now got humidity dropped right down but it doesn't have any water in at the moment because it seems even a 20 ml drop of water boosts it right up. But now I'm panicking the temp on the machine is to low as the didigital inside is reading only 35.5!!! What am I to do! I tried a mouth digital thermometer and that reads 37.1. So many different readings. I'm so worried, and don't know if we should higher the temp on the actual incubator until the inside thermometer gets to 37.5 instead of 35.5

Any advice would be great!!
Is this going to completely ruin everything?? it's the first full day we have had them in. Thanks in advance
 
Last edited:

Meplus3

Hatching
May 27, 2020
14
0
8
Here is the picture of the inside reading
 

Attachments

  • IMG_20200527_212347.jpg
    IMG_20200527_212347.jpg
    332 KB · Views: 6

Meplus3

Hatching
May 27, 2020
14
0
8
Until an expert comes along I would advise you to split the difference on temperature.
thank you, I've put 1 ml of water in and the humidity has slowly risen to 40% So far.
I've raised the temp of the machine but still showing 36.6 inside at the moment
 

Meplus3

Hatching
May 27, 2020
14
0
8
Would I be better to get one of these instead?? I didn't think it would be so stressful 😥 my girls will be so disappointed if something goes wrong

,
 

Attachments

  • Screenshot_20200527_224314_com.android.chrome.jpg
    Screenshot_20200527_224314_com.android.chrome.jpg
    199.2 KB · Views: 5

New posts New threads Active threads

Top Bottom