Help needed with R-com king suro 20

Discussion in 'Incubating & Hatching Eggs' started by marlene, Sep 2, 2016.

  1. marlene

    marlene Chillin' With My Peeps

    659
    3
    128
    Aug 17, 2011
    UK
    Can anyone help me with information on the pumping system. I have set up the incubator but I am having problems with the pumping system that regulates the humidity. When it pumps, the water is not being pumped up enough to reach the top of the hose and go into the incubator. If I raise the bottle that holds the water to above the incubator hight the water travels up the pipe and into the incubator, but then the humidity becomes too high.
    Not sure what I am doing wrong. Would really appreciate any help from others that have this incubator as I have eggs waiting to set in it.
    This unit was bought used so I can not contact the manufacturers about the problem.
     
  2. CuzChickens

    CuzChickens CountryChick

    5,511
    1,378
    306
    Apr 24, 2016
    Virginia
  3. marlene

    marlene Chillin' With My Peeps

    659
    3
    128
    Aug 17, 2011
    UK
    Thank you for the link, I have seen it while trying to research my problem.
    Had hubby look at it yesterday, and it seems the tubing going through the pump had become loose. He cut it and put it back as recommended by the set up instructions, and hey presto, works great now.
    It has been stored for a few years so maybe that caused the pipe to loosen. It is now maintaining temp abd humidity like a dream.
     
  4. CuzChickens

    CuzChickens CountryChick

    5,511
    1,378
    306
    Apr 24, 2016
    Virginia
    Oh, good! I am glad its fixed! Happy incubating!
     
  5. hearthorses

    hearthorses New Egg

    2
    0
    9
    Feb 29, 2016
    Any opinions/comments on the r-com 20 ? Getting ready to incubate some eggs on a small scale?
     

BackYard Chickens is proudly sponsored by