JUST ABOUT FED UP!

HickoryHollow

Songster
7 Years
May 28, 2012
423
52
113
Bolivar, Ohio
But not quite. My first hatch, I had temp swings, power outages and every other catastrophe you could imagine. I only had a 12% hatch rate. But then again I DID have a 12% hatch rate. My second batch was a spur of the moment decision to do. My wife had washed all the eggs we had on hand, but I decided to take a chance on them. Didn't pay off at all.......got a big 0% this time.

I am about to start a batch of 40. This time, fresh eggs, stored properly. I even have them in an egg turner while I collect enough. They will go in Saturday. If this attempt fails, I think I will hang it up. We will see what happens.
 

sumi

Égalité
Staff member
Premium member
8 Years
Jun 28, 2011
39,157
25,178
1,302
Tipperary, Ireland
That really stinks! What make/model incubator do you use and what was your temp (most of the time) and humidity in there? Let's see if we can figure out what the problem is.
 

Sally Sunshine

Crossing the Road
Premium member
7 Years
Aug 23, 2012
57,536
10,498
957
But not quite. My first hatch, I had temp swings, power outages and every other catastrophe you could imagine. I only had a 12% hatch rate. But then again I DID have a 12% hatch rate. My second batch was a spur of the moment decision to do. My wife had washed all the eggs we had on hand, but I decided to take a chance on them. Didn't pay off at all.......got a big 0% this time.

I am about to start a batch of 40. This time, fresh eggs, stored properly. I even have them in an egg turner while I collect enough. They will go in Saturday. If this attempt fails, I think I will hang it up. We will see what happens.
I posted a response on the Diary thread for you
not sure you got to see it yet
 

HickoryHollow

Songster
7 Years
May 28, 2012
423
52
113
Bolivar, Ohio
That really stinks! What make/model incubator do you use and what was your temp (most of the time) and humidity in there? Let's see if we can figure out what the problem is.
The first was in a borrowed LG. The second in a new Farm Innovators I bought. Humidity in both during incubation was around 30%. For the first on, I ran humidity up to about 70% and when I eggtopsied it looked like they were too large, never internally pipped. So on the second batch I dropped the humidity down to about 55%. Temp around 100. I haven't opened them yet, but today is day 23. I will tonight. None were pipped this morning. On my next attempt, I am going to weigh EVERY egg!
 
Last edited:
Top Bottom