Mini Advance Stopped working :(

Discussion in 'Incubating & Hatching Eggs' started by aquamoonbeam, Nov 25, 2012.

  1. aquamoonbeam

    aquamoonbeam New Egg

    5
    0
    7
    Mar 9, 2010
    I am on day 18 of my button quail hatch and i wake up and sometime during the night something happened to the incubator. There was no power outage at all but my incubator was non responsive to everything. One of my eggs had pipped this morning. :( This is super depressing and I can't get ahold of brinsea. I tried a different power adapter but the new one didn't work either so it has to be something with the incubator and I can't find any info on that. It will not even turn on. The rest of the days it has worked just fine and I have been super happy with it. I made a makeshift incubator to get the temperature back up, but I am so worried about the babies.
     
  2. aka Rachel

    aka Rachel Chillin' With My Peeps

    I'm sorry, I have no good news for you as my mini adv did the same darn thing in the middle of a hatch. It still had a display when I found mine but once unplugged, it never came back on and I scoured the internet to find any info to no avail.

    I have a wood stove, so I set the eggs in front of it covered with a towel while I tried to get the brooder up to 100 or so while I threw together a cooler 'bator. Meanwhile the temps were all over the place, I had almost lost hope. We candled once the incubator was ready and they were still moving and growing! Mine are in lockdown, hatch day is tuesday. After all they have been thru I can't believe they will actually hatch or be ok till it happens.

    Anyway, I feel your pain. I loved my brinsea mini adv. I will purchase another when I can afford to again. Or might purchase the next model up but its about $500!
     

BackYard Chickens is proudly sponsored by