All eg gs in the bator dead after the 120F temp. spike, need support!

Discussion in 'Incubating & Hatching Eggs' started by bock, Apr 2, 2009.

  1. bock

    bock Chillin' With My Peeps

    2,281
    10
    191
    Oct 10, 2008
    Northern CA
    [​IMG] [​IMG] The 16 eggs I had when the Temp. went to 120F are ALL dead. [​IMG] I wanted them to hatch sooooooooooooooo bad. [​IMG] [​IMG] [​IMG] [​IMG]



    Whyyyyyyyyyy, Whyyyyyyyyyyyyyy
     
  2. newnanchic

    newnanchic Chillin' With My Peeps

    Jan 3, 2008
    Newnan, Georgia
    I am so sorry !!! Just try and try again !!! We have all had mishaps but we just have to keep on keeping on !!!
     
  3. Mrs. Turbo

    Mrs. Turbo Chillin' With My Peeps

    Jan 26, 2009
    ky
    we had that happen a few weeks ago, not fun when the bator is full and 4 days from hatch.

    Sorry to hear it happened to you too.
     
  4. old mill poultry

    old mill poultry Chillin' With My Peeps

    379
    0
    129
    Mar 10, 2009
    What kind of bator do you have? By the way so sorry about your hatch, very heartbreaking. I lost my first three hatches til I got a better bator, just keep trying.
     
  5. jensaisquoi

    jensaisquoi Out Of The Brooder

    74
    0
    29
    Jan 24, 2009
    Livingston, Montana
    That happened to me two weeks ago. It's extremely disheartening--especially since two little ones made it to the last week and then quit. I caught the spike early on but obviously there was some damage--also could've been cold temps in shipping...
    But I'm going again (now with a new incubator from Brinsea--the eco model) and I'll keep going till I get what I want--freedom from hatcheries and the maybe-we-have-it at the feed store....

    Jump back in and do it again!! [​IMG]



    Best,

    Jen
     

BackYard Chickens is proudly sponsored by