Help!! did I just lose my hatch??

Discussion in 'Incubating & Hatching Eggs' started by miss_thenorth, Aug 9, 2009.

  1. miss_thenorth

    miss_thenorth Songster

    Dec 28, 2007
    SW Ont, Canada
    The hydro was out for 5 hours, and the eggs should be hatching today-tomorrow. Temp got down to 95. Did I just lose them all??
     
  2. ranchhand

    ranchhand Rest in Peace 1956-2011

    13,295
    34
    291
    Aug 25, 2008
    SC
    No, probably not. Get everything back to normal and relax. Might delay the hatch a bit, but don't worry about what you can't change.

    Happy hatching! [​IMG]
     
  3. matthew1985

    matthew1985 Songster

    230
    1
    109
    May 18, 2009
    dover,delaware
    :)this far along they should be just fine.
     
  4. miss_jayne

    miss_jayne Lady_Jayne

    Jun 26, 2008
    Columbiaville, MI
    no way! you're still in the game! can't wait to see a post of a bunch of fuzzies! [​IMG]
     
  5. mom2chicksandpups

    mom2chicksandpups Songster

    Apr 18, 2009
    Southeast Alabama
    I've had my temp. fluctuate a bit near the end and the eggs still hatched. I actually got up this morning to find that one of my incubators had got up to 102 degrees, but the eggs are hatching as I type this. I just turned it down as soon as I noticed the high temp.
     
  6. DANNY

    DANNY Songster

    Mar 27, 2009
    GAINESVILLE, GEORGIA
    Actually that's how people make a lot of mistakes is by adjusting at every little change of temperature. It is best to leave it alone and give it a chance to level back out.
     

BackYard Chickens is proudly sponsored by: