HELP!!! Incubator humidity not working and keeps beeping!!!

Majak5

Songster
Feb 20, 2018
186
150
121
Lismore NSW AUSTRALIA
I have a HHD 24 egg incubator and it was working fine( other than the temp being out but I’ve set it up with a temp and humidity gauge that works) but the humidity usually works fine and says the proper humidity but today it either shows up as 26% or EE shows on the screen and it beeps. The water Chanel’s are full so I don’t know what it’s doing. I’ve turned it off and on and I’ve completely unplugged it and everything, I don’t know why it is doing this. Anyone know anything?
A8E9821C-7D78-46B9-AC66-CA528E6C2B95.jpeg
 

Pyxis

Hatchi Wan Kenobi
Project Manager
Premium Feather Member
9 Years
Mar 27, 2012
21,162
48,662
1,192
Vermont
My Coop
My Coop
That looks like an incubator malfunction, so I can't help you with that since I'm not familiar with that brand of incubator (it sounds like you've already had a lot of problems with it so after this hatch if I were you I'd return it and get something else).

But it does look like you've got a backup hygrometer there so I'd just go by that one if you've calibrated it and found it to be accurate.
 

tjb

Songster
May 24, 2017
528
568
192
southeast texas
I have a HHD 24 egg incubator and it was working fine( other than the temp being out but I’ve set it up with a temp and humidity gauge that works) but the humidity usually works fine and says the proper humidity but today it either shows up as 26% or EE shows on the screen and it beeps. The water Chanel’s are full so I don’t know what it’s doing. I’ve turned it off and on and I’ve completely unplugged it and everything, I don’t know why it is doing this. Anyone know anything? View attachment 1305565

I had the same issue with the exact same incubator... I tried everything to get it to stop beeping--even tried to follow the wire to snip the humidity sensor. Ended up getting a different incubator.
 

Majak5

Songster
Feb 20, 2018
186
150
121
Lismore NSW AUSTRALIA
I had the same issue with the exact same incubator... I tried everything to get it to stop beeping--even tried to follow the wire to snip the humidity sensor. Ended up getting a different incubator.
Do you know how to get the egg turner on the HHD to turn automatically every however long it is meant to turn them, at the moment it only turns when I click the reset button
 

Clyde Timms

In the Brooder
May 27, 2017
10
7
39
I have a HHD 24 egg incubator and it was working fine( other than the temp being out but I’ve set it up with a temp and humidity gauge that works) but the humidity usually works fine and says the proper humidity but today it either shows up as 26% or EE shows on the screen and it beeps. The water Chanel’s are full so I don’t know what it’s doing. I’ve turned it off and on and I’ve completely unplugged it and everything, I don’t know why it is doing this. Anyone know anything? View attachment 1305565

I have 3 of these 24 egg incubators. When the EE is displayed the Sensor for that has failed. This may be due to a bad Sensor or a bad connection where it is plugged into the mainboard. The Humidity Sensor is over against the side in the bottom tray and is outside the water canals. It is not supposed to ever get water directly on it but if it is overfilled it might. One way to quickly see if the Sensor is working is to blow your breath directly on it thru a straw. The humidity will quickly rise up to above 75%. The only real issues that I am having with mine is the top cover keeps popping out of the bottom half on one side or the other after running a couple of days. When they do this the control will have to cycle more and it will lose humidity faster.
 

Juliedance

Hatching
May 19, 2018
1
0
1
Has anyone figured out how to fix if the humidity sensor isn't working aside from turning it on and off? I've done that several times. I ran the unit for three weeks without a beeping problem. Turned it off overnight and now I can't get it working again without beeping. Says 76% humidity and EE. I even tried taking some of the water out.
 

Carolina Oaks

Hatching
Feb 26, 2020
3
4
8
Once the sensor goes "truly" bad, I don't think you can fix it. You can try cleaning it, but you risk damaging it if it isn't already damaged. There may be a way to order a new one if you could find the part. It looks like a really cheap humidity sensor. What I did is just bypass the sensor by cutting the wires leading to it, exposing about 2mm of wire on the ends, and putting both ends into the water tray. The water will give them enough resistance to read about "69" on the humidity display. This will stop the beeping. Of course, don't forget to put in an external sensor of your choice to monitor humidity after that. It's just a cheap sensor, other than that the incubator has worked fine for me.
 

EdmundUrbanBXL

In the Brooder
May 1, 2020
7
36
25
I have 3 of these 24 egg incubators. When the EE is displayed the Sensor for that has failed. This may be due to a bad Sensor or a bad connection where it is plugged into the mainboard. The Humidity Sensor is over against the side in the bottom tray and is outside the water canals. It is not supposed to ever get water directly on it but if it is overfilled it might. One way to quickly see if the Sensor is working is to blow your breath directly on it thru a straw. The humidity will quickly rise up to above 75%. The only real issues that I am having with mine is the top cover keeps popping out of the bottom half on one side or the other after running a couple of days. When they do this the control will have to cycle more and it will lose humidity faster.



you can place the white isomo that pack with the incubator and cut a hole for the main electric.

image.jpg
 

New posts New threads Active threads

Top Bottom