help my incubator doesn't light up!

Discussion in 'Incubating & Hatching Eggs' started by stitchc, Jan 8, 2009.

  1. stitchc

    stitchc New Egg

    4
    0
    7
    Jan 8, 2009
    :(HI I'M MARGYC JUST REGISTERED I HAVE A SMALLHOLDING IN THE NORTH OF ENGLAND WITH GOATS GEESE AND HENS. I HAVE DECIDED FOR THE FIRST TIME TO USE AN INCUBATOR TO HATCH SOME EGGS BUT THE BULB HASN'T LIT UP DESPITE BEING ON FOR 9 HOURS! the instructions are neither use nor ornament! I HAVE CHANGED THE BULB CAN ANY BODY SHED ANY LIGHT (HAHAHAHA) on this for me.
     
  2. rooster-red

    rooster-red Here comes the Rooster

    7,008
    19
    261
    Jun 10, 2007
    Douglasville GA
    Sounds to me like you have a bad thermostat.

    Is this a home made bator?

    [​IMG]
     
  3. BirdBrain

    BirdBrain Prefers Frozen Tail Feathers

    May 7, 2007
    Alaska
    I am assuming that you have a wafer thermostat. That being assumed, have you turned the key clockwise? Try doing that until the wafer engages the switch (little button) and you should hear a small click as the thermostat switches on. If your light doesn't come on then it may be a connection in the wiring. Is this a new bator?
     
  4. stitchc

    stitchc New Egg

    4
    0
    7
    Jan 8, 2009
    yeah its new a covatutto 6. i'll try turning the switch thing. thanx for such speedy replies. will get back.[​IMG][​IMG]
     
  5. rooster-red

    rooster-red Here comes the Rooster

    7,008
    19
    261
    Jun 10, 2007
    Douglasville GA
  6. stitchc

    stitchc New Egg

    4
    0
    7
    Jan 8, 2009
    no joy, my sparky friend is going to have a gander in the morning. i have 6 buff orp eggs being delivered on saturday. fingers crossed. [​IMG][​IMG]
     

BackYard Chickens is proudly sponsored by