Homemade Egg Incubator

Discussion in 'Incubating & Hatching Eggs' started by BENNY, Dec 31, 2010.

  1. BENNY

    BENNY Out Of The Brooder

    20
    0
    32
    Jul 10, 2010
    I needs some help. I just built a homemade incubator and used a hot water heat regulator from Lowe's, 60 watt bulb, an old igloo cooler, pc fan, and the system works well but it comes on @ 90 degrees, runs for 9 minutes, get the incubator up to 102 degrees and shuts off for 16 minutes and cycles begins again. This temperature difference is to wide and would like to know how to close this gap. I have not added any ventilation yet and have not added any water for the humidity. I will try a lower watt bulb maybe, or done I need a better regulator. Thanks for any help. Benny
     
  2. KatieBugg

    KatieBugg Chillin' With My Peeps

    293
    2
    118
    Dec 21, 2010
    Holts Summit, MO
  3. rebel yell

    rebel yell Chillin' With My Peeps

    1,386
    19
    161
    Jun 27, 2010
    Alabama
    OK, you need to move the thermostat, place it about 1 inch from your light bulb, metal side facing the bulb & it will vary about 2 deg. if that, it will work, let us know how you come out
     
    Last edited: Dec 31, 2010
  4. gitlost80

    gitlost80 Trigger Pullet

    491
    0
    131
    Mar 27, 2009
    Reno/Sparks
    Maybe get a "lamp dimmer switch" at home depot for $10. Plug your lamp right into it. You can brighten/dim the bulb to find that perfect temp.
     
  5. BENNY

    BENNY Out Of The Brooder

    20
    0
    32
    Jul 10, 2010
    That Fixed my problem. Thanks You guys are great. Benny


    Quote:
     

BackYard Chickens is proudly sponsored by