I just did my eggtopsy on my unhatched eggs...

jimandkira2002

In the Brooder
Mar 25, 2015
66
4
48
and 4 out of my 6 that didnt hatch (1 chick hatched) looked like they were hard boiled!!! My temps were never higher then 101 mostly 100 on 4 different thermometers! I dont know what went wrong. I turned them 3-5 times a day. I have 2 fans in the incubator to keep air moving so to cut down on the chance of hot spots. My humidity was a little hard to control but I kept it above 30% until lockdown. Im wondering if Im having such an issue with getting eggs to hatch from some unknown issue with my incubator?!? I set 6 more eggs 9 days ago and it looks like all of them are not developing too. Im ready to throw the hat in and stop trying to hatch chicks. I did so much research and thought I knew somewhat what I was doing but obviously I dont. Im just doing this for my daughter to see so its not like I need to do this. I just want too because of all the money I put into this already. We had one successful chick hatch so maybe thats enough :/ Im so upset and frustrated now.
hit.gif
he.gif
 

Drewnkat

Songster
11 Years
Mar 27, 2008
176
41
191
Georgia
Have you checked your thermometers to make sure they are registering accurately? Do you have one that records daily high/low temps to see if your temperature spiked up too high at some point?

I'm sorry things haven't been going well. I hope you are able to work out what's going on.
 

jimandkira2002

In the Brooder
Mar 25, 2015
66
4
48
I dont know how to test them. But I have 4 and all of them are withing .5 degrees from each other. 2 are on the incubator units I have and 2 are store bought. 1 of the store bought ones is specifically made for incubators and the other is a Lowe's one and it does record the highs and lows of the day. It never got higher then 101 :( I also keep records of all my temp and humidity checks daily :(
 

blkjak

Songster
5 Years
Apr 18, 2014
734
76
120
Manitoba Canada
I have a styrobator. No fan. I found that my hatches were not turning out as well as I had hoped. This last hatch I backed the temp off to 99 and had a much better hatch. 26/40 with green/blue eggs. The hatch before I only hatched 6/32 with 101 for temp.
 

jimandkira2002

In the Brooder
Mar 25, 2015
66
4
48
I have a home made cooler incubator. The first batch of eggs I got from a friends flock. We can't keep the chicks because of our HOA so she is taking back the one chick that hatched. The 2nd batch of eggs I got from a local farm. I thought it was that the eggs were not fertile and that's why I had such an issue with the first batch till I opened them up last night. They look like a hardboiled egg. Whites are white and solid and yokes were solid and some were sofe or a little runny with no growth at all. The other 2 that I opened were still liquid inside and deffinetly were not fertilized because there was no change what so ever. This 2nd batch doesn't look like anything is growing inside one day 9. They could be infertile too but all 6 don't look good.
 

WVduckchick

🐓🦆 For the Birds! 🦆🐓
Premium Feather Member
6 Years
Feb 9, 2015
48,229
126,517
1,692
West Virginia
My Coop
My Coop
Sounds to me like they were definitely too hot. Inaccurate thermometer? Maybe the fans are moving too fast and affecting the temp readings?? Position of the thermometer in relation to the eggs and fans... Those would be the first things I would look at.
 

New posts New threads Active threads

Top Bottom