Incubator loaded for First Time

FloorCandy

Songster
Apr 15, 2020
1,430
2,642
231
I just had to toss 21 Serama eggs. They started to develop then stopped. Candled at 21 days and just a black dot no chick... Seramas usually take 19 days...I have no idea what happened. This isn’t my first time either... I’ve been having bad turn outs the last couple of times...just never zero... 😢
Do you have a separate thermometer and hygrometer in the incubator? Maybe the heating element is weakening or the fan is weaker or some minor change in your incubator that caused this.
 
Jun 29, 2019
13
31
54
Do you have a separate thermometer and hygrometer in the incubator? Maybe the heating element is weakening or the fan is weaker or some minor change in your incubator that caused this.
No, I don’t have the extra equipment. I don’t think that’s an issue because I had Turken eggs in there also and they hatched fine.
 

MDBird

Chirping
Jul 19, 2020
143
178
83
I am very new at this but I think that incubator temps do have to be monitored because they can change between hatches. At least I know mine has had to be changed before because the temp went down.
 
Jun 29, 2019
13
31
54
I am very new at this but I think that incubator temps do have to be monitored because they can change between hatches. At least I know mine has had to be changed before because the temp went down.
I have a nurture right 360 it has a digital thermostat and a built in humidity reader also.
 

MDBird

Chirping
Jul 19, 2020
143
178
83
I have a nurture right 360 it has a digital thermostat and a built in humidity reader also.
That was the incubator that I previously used that had the temperature change through out the hatch. Shown by two thermometers inside the incubator.
 

New posts New threads Active threads

Top Bottom