100% loss

Leaches123

Chirping
Apr 6, 2016
48
48
84
Hi everyone,
So we've come to the end of incubation and we have not had one survive:( this is about my 4th time, but this time was with a new incubator. I've never had a movement one before and always had 99% live rate, even without moving them every day. so autopsy wise half were duds, a couple i think died from too high humidity(as were surrounded by fluid), a couple early cooked (the temp kept changing every time the tray moved) and finally chicks that were due to hatch were all upside down and a couple had head under legs. So I guess my question is has anyone had trouble with the moving trays and a fan?
 

Leaches123

Chirping
Apr 6, 2016
48
48
84
Sorry about that.
Are you using aux meters or trusting the factory meters?
What was your Humidity level for early set and after day 18?
What region do you live in?
Was your oven in a draft free room?
:pop
hey, I was just going by the machine, I should've checked early on. I put my thermometre in after though and it was matching the temp. humidity was 61/63% early on and 70+ for late which i believe was too high. I'm in nsw Australia, so spring time. we had really great weather early in the setting but then had a week of cold and rainy. i tried to make the room as draft free as possible but it would've had a bit of changing airflow at times.
 

ShannonR

Free Ranging
5 Years
Sep 17, 2015
2,535
16,788
552
What were you saying, "even without moving them every day"? I take this to mean turning your eggs, correct?
Just how often do you turn the eggs during incubation? With 4 incubations and two incubators, and zero success, I would be looking for a user error, lol
 

Leaches123

Chirping
Apr 6, 2016
48
48
84
What were you saying, "even without moving them every day"? I take this to mean turning your eggs, correct?
Just how often do you turn the eggs during incubation? With 4 incubations and two incubators, and zero success, I would be looking for a user error, lol

hi, with my other incubator I had 99% healthy hatch rate, with that it didn't have an automatic turner so I would turn the eggs once a day maybe and the eggs were just on a flat surface.. with my new incubator it turns automatically every 2 hours and i removed it and put the eggs down flat at day 17 like it says..
 

2 many chickens

Crowing
Jan 14, 2017
2,054
5,512
352
hi, with my other incubator I had 99% healthy hatch rate, with that it didn't have an automatic turner so I would turn the eggs once a day maybe and the eggs were just on a flat surface.. with my new incubator it turns automatically every 2 hours and i removed it and put the eggs down flat at day 17 like it says..
Highly doubt your turning tray is the problem. Your humidity is. 60% humidity is too high for the beginning.
 

ShannonR

Free Ranging
5 Years
Sep 17, 2015
2,535
16,788
552
hi, with my other incubator I had 99% healthy hatch rate, with that it didn't have an automatic turner so I would turn the eggs once a day maybe and the eggs were just on a flat surface.. with my new incubator it turns automatically every 2 hours and i removed it and put the eggs down flat at day 17 like it says..
Ok, sorry, I misread part of the original post.
 

New posts New threads Active threads

Top Bottom