Fertile but not developing

Discussion in 'Incubating & Hatching Eggs' started by cutiepieacres, Apr 16, 2009.

  1. cutiepieacres

    cutiepieacres Chillin' With My Peeps

    472
    3
    131
    Jan 20, 2009
    S. CA
    I have two Marans hens that I want to get some chickies out of but their eggs will not develop. I have tried for the last few months with about 40 eggs and no devleopment of any egg.

    I know the rooster is doing his job, as I have 3 buff orps in the pen as well and getting 100% hatches. And obviously the incubator is doing its job.

    I have cracked open the eggs and they look to have the "bullseye."

    One hen has been laying since October the other since Feb.

    What is going on with these girls and their eggs!
     
  2. chicks for better health

    chicks for better health Chillin' With My Peeps

    452
    0
    139
    May 4, 2008
    West Glenville, NY
    Do the hens have alot of feathers over there vents? I had to trim my SLW around the vent area because they really weren't getting fertilized.

    You might also want to check the temp in your bator with a different thermometer

    Hope this helps
     
  3. cutiepieacres

    cutiepieacres Chillin' With My Peeps

    472
    3
    131
    Jan 20, 2009
    S. CA
    Ill check their vents....

    The incubator is for sure working perfectly, I have chicks all over the place from other eggs and getting very high hatch rates.
     
  4. Smoky73

    Smoky73 Lyon Master

    1,616
    10
    181
    Feb 8, 2007
    Colorado
    Have you actually seen him breed your Maran hens or just the others? Maybe he is trying to breed the Marans but not succeeding in getting the job done. Clip the feathers around the vents and up on the girls, including the tails. That should help.
     

BackYard Chickens is proudly sponsored by