Got a bad hatch going on...

Discussion in 'Quail' started by lagpmgdsls, Aug 12, 2010.

  1. lagpmgdsls

    lagpmgdsls Songster

    330
    2
    131
    Apr 6, 2009
    Not sure what I did wrong. These are my eggs and I have hatched lots of them before with success but for some reason this hatch is not going well. I have 82 eggs....8 have hatched with started 2 nights ago. 2 of the chicks can't seem to stay upright...they just flail around on their backs. If I hold them up they are fine and will eat and drink. Another one does not look good at all....hasn't seemed to absorb all the yolk sac either so I don't have much hope for that one.

    No popcorn this time [​IMG]
     
  2. Stellar

    Stellar The Quail Lady

    4,203
    39
    261
    Feb 6, 2010
    Tampa Bay
    I have had that happen before and then I realized I stuck the incubator in front of the window and had baked the eggs! Silly me!

    Could you provide us with more info so we can help you better?

    Example:

    Temperature:
    humidity:

    The more details the better! [​IMG]
     
  3. lagpmgdsls

    lagpmgdsls Songster

    330
    2
    131
    Apr 6, 2009
    temps and humidity have been fine...although we were out of town for a few days and when I came home the clocks were flashing so the power went out....probably just for a second but who knows.

    I think the grand total is 26...2 which have died. This hatch has dragged on for days...I have ones born almost 5 days ago and new ones from just last night...the first born are already starting to get feathers..barely but I see them coming in. Just when I think its done I will go to turn off the bator and theres more...LOL
     
  4. Stellar

    Stellar The Quail Lady

    4,203
    39
    261
    Feb 6, 2010
    Tampa Bay
    It does seem like there was a temperature issue with your hatch. If there is a delay, usually it's lower temp. I am glad you got some chicks out of the hatch though [​IMG]
     

BackYard Chickens is proudly sponsored by