how do you get your wafer to work correctly? confussing to me????

Discussion in 'Incubating & Hatching Eggs' started by happyhens44, Jan 18, 2011.

  1. happyhens44

    happyhens44 BroodyAddict

    Apr 25, 2010
    Northern WI
    I finally got mine set set up and my incubator has been running since yesterday night. But if I put it 1 little notch, before turning off. (If you turn it to far the light goes off etc) well I keep it one notch from the light going off, But the temp is still at 105! [​IMG] Any suggestions.
     
  2. robnms

    robnms Chillin' With My Peeps

    207
    1
    114
    Jul 9, 2010
    Gulf Coast MS
    Patience Grasshopper!!! That thermostat needs time to adjust, it takes time to level off. If it's at 105, turn it 1 whole turn down (it should be clockwise) and leave it for an hour or two to level off or just pull the top off for a few minutes to let the heat out. Is this a new bator or used and where is your thermostat? It should be at egg level. If it's new, you should have instructions to get it close to target temps. Did you screw the wafer on the adjustment rod untill you heard a click, it's not a very loud click and if you go too far, it might damage the wafer. I hope this helps.
     
  3. happyhens44

    happyhens44 BroodyAddict

    Apr 25, 2010
    Northern WI
    Haha My dad tells me that " Patience Young Grasshopper" Anyways thanks Im learning that slowing moving it down tell it clicks off then it will eventually come on so Ill move the thing tell it clicks off,So far its at 102.7 what temp would be perfect? I have a fan, and egg turner in there if that helps deside what temp I should have?
     
  4. jeslewmazer

    jeslewmazer Chillin' With My Peeps

    Nov 24, 2009
    Mississippi
    Temp should be right around 99.5F
     

BackYard Chickens is proudly sponsored by