My hatch rate has been horrible this year!dieng before they even pip.

tobinvalley

In the Brooder
Feb 1, 2016
8
0
22
seem to be dieng around day 18 or 19. these pics were 8 out of 10 that i opened up on day 20. Ive hatched over a 1000 chics and have never had this happen. I use a r com and have tested its numbers...???
Help please!!!
 

Attachments

  • 20180329_212952.jpg
    20180329_212952.jpg
    163.7 KB · Views: 6
  • 20180329_213116.jpg
    20180329_213116.jpg
    212.1 KB · Views: 6
  • 20180329_213120.jpg
    20180329_213120.jpg
    196.1 KB · Views: 7
  • 20180329_212955.jpg
    20180329_212955.jpg
    146.6 KB · Views: 6
  • 20180329_212910.jpg
    20180329_212910.jpg
    297.3 KB · Views: 6
  • 20180329_212931.jpg
    20180329_212931.jpg
    207.4 KB · Views: 6

Pyxis

Hatchi Wan Kenobi
Project Manager
Premium Feather Member
9 Years
Mar 27, 2012
21,207
48,904
1,192
Vermont
My Coop
My Coop
Did you open up the internal membranes to see if there was excess liquid in there? Late deaths are usually due to humidity issues, with humidity having been either too high or too low throughout the first 18 days.
 

tobinvalley

In the Brooder
Feb 1, 2016
8
0
22
I turned the humidity down to 40 yesterday. Ive tested my humidity seperately from the rcom thinking maybe that is it but it tested out fine. I had it at 49 before yesterday. I am in missouri and its been raining for 2 weeks(90%humidity) so maybe atmospheric humidity got me somewhere in there.
 

New posts New threads Active threads

Top Bottom