Problem with hatch?

Discussion in 'Incubating & Hatching Eggs' started by tdballew, Apr 9, 2009.

  1. tdballew

    tdballew Out Of The Brooder

    15
    0
    22
    Oct 31, 2008
    Northwest Georgia, USA
    Please help me learn! I just hatched 2 out of 20 and the 18 that did not hatch was dead in shell and I could hear fluid in the egg. Was my Humidity to high? I keep it at about 30% 1-18 day and then up it to 50%-60% day 19-21. Please help! I use a GQF 2362N with and egg turner.

    Thanks
    Dwayne
     
  2. duck&chickencrazy

    duck&chickencrazy Chillin' With My Peeps

    Dec 2, 2008
    Indiana
    i think it was supposed to be 40% humidity the first 18 days
     
  3. willowcol

    willowcol Chillin' With My Peeps

    Oct 10, 2008
    Macclesfield NC
    Well I do mine 25-35 day 1-18 and had no problem. Maybe you humidity guage was off? Not sure why they would have drown, did you open to check if they had just stopped developing and that they had pipped the membrane inside the egg?
     
  4. CindyS

    CindyS Chillin' With My Peeps

    666
    3
    151
    Apr 14, 2008
    Geneseo, Illinois
    What temp are you incubating at, did you break open the eggs? was the sloshing just rotton egg or dead embryo? If the chick dies at around day 15, there will be alot of liquid around the chick. I am going to say its not a humidity problem but improper temperature. Did the chicks hatch on day 21?
     
  5. Guitartists

    Guitartists Resistance is futile

    Mar 21, 2008
    Michigan
    You'll find all kinds of numbers in the humidity game [​IMG] Maybe your hydrometer is reading incorrectly or more likely that possibly there is some other reason for the others dying. Do you sanitize thoroughly in between hatches? Bacteria can cause chicks to die. Did you have any temp spikes or anything else that went awry? And I agree... did you check to see that they were dead? Did you notice anything else...smells, etc?
     
  6. tdballew

    tdballew Out Of The Brooder

    15
    0
    22
    Oct 31, 2008
    Northwest Georgia, USA
    The temp was always 100 and I always sanitize after every hatch. My first hatch was 14 out of 16, second hatch was 4 out of 20 and the third hatch was 2 out of 20. I do not know what has gone wrong with the last two, however, my last 2 hatches were from shipped eggs and my first hatch was from some egg that someone gave my (not shipped)

    Thank for any help!!

    Dwayne
     

BackYard Chickens is proudly sponsored by