R-Com Incubator help, please

talkturkey

Songster
10 Years
May 4, 2009
36
26
104
Anyone have an R-Com Max 20 incubator that may be able to help? I purchased one off of ebay at a great price, however, it doesn't seem to be heating properly. Hoping someone may be able to give me some tips on what to check? Otherwise I'll be returning it. Thank you in advance for any help!
 

Fire Ant Farm

Get off my lawn
May 5, 2015
6,170
2,557
356
South Texas
I have one, but had no problems with heating in it. But...

One thing to check before you return it - make sure you have the top on correctly/snuggly. Sounds silly, but I was incubating and after candling I couldn't get the temp to get back up. I was freaking out. Then I realized I had set the top back on slightly off center, and there was a gap. It can happen if the top goes on backwards, too - doesn't fit right.

That's the only thing I can offer. If that's not it, I would totally return it.
 

talkturkey

Songster
10 Years
May 4, 2009
36
26
104
Thank you for the help. I fiddled with it some more, including the factory reset option and it is now maintaining the heat. Could have very well have been the lid issue. Thank you again and I'll make sure the lid sits properly in the future.
 

Fire Ant Farm

Get off my lawn
May 5, 2015
6,170
2,557
356
South Texas
Super! Glad to hear it! The lid thing is hard to see if it's not seated correctly. (That happens with other brands as well - I have a Brinsea, it can happen there, too, so it's a generally good thing to double check after opening the incubator to candle, etc.)
 

New posts New threads Active threads

Top Bottom