Why? Fully formed chicks not hatching?

Discussion in 'Incubating & Hatching Eggs' started by Mrs.brown, May 29, 2011.

  1. Mrs.brown

    Mrs.brown Chillin' With My Peeps

    218
    1
    101
    Apr 14, 2011
    In a coop
    The last two times I have tried to incubate (and probably this time too) I have had fully formed chicks that haven't pipped. What ever the reason I have had 0% hatches. Tempretures have normally been 98-100 with a few spikes and downs. Humidity has been 20-34% and 40-50% during lockdown. What am I doing wrong?
     
  2. MetalSmitten

    MetalSmitten Chillin' With My Peeps

    575
    8
    131
    Apr 11, 2010
    bloomington, indiana
    try increasing your humidity. you'll see a lot of different answers, but what works for me is 25-40% during incubation and 60-70% during lockdown.

    otherwise, have you checked your thermometer and hygrometer to make sure they're correct?
     
  3. Mrs.brown

    Mrs.brown Chillin' With My Peeps

    218
    1
    101
    Apr 14, 2011
    In a coop
    Quote:I haven't tried yet. How do you do it with the hygrometer?
     
  4. MetalSmitten

    MetalSmitten Chillin' With My Peeps

    575
    8
    131
    Apr 11, 2010
    bloomington, indiana
  5. Mrs.brown

    Mrs.brown Chillin' With My Peeps

    218
    1
    101
    Apr 14, 2011
    In a coop
    Quote:Thanks! Does it have to be table salt?
     
  6. MetalSmitten

    MetalSmitten Chillin' With My Peeps

    575
    8
    131
    Apr 11, 2010
    bloomington, indiana
    y'know, i'm not totally sure, but i personally wouldn't try a different kind. i don't know enough about salt's effects on humidity to really say. =/ sorry.
     

BackYard Chickens is proudly sponsored by