Trying to solve a mystery

Discussion in 'Incubating & Hatching Eggs' started by GBov, Jan 14, 2011.

  1. GBov

    GBov Chillin' With My Peeps

    617
    8
    154
    Apr 3, 2009
    Just too my courage in both hands and opened one of the eggs that are now 25 days set. The chick was fully formed but still had a large yoke in the egg with it. It didnt move or twitch so presumably it was dead. No smell and some of the veins on the yoke sack were brown and a few were still red so I dont think it had been dead for long.

    Is it poss. that their very cold start - unheated hen house during a hard freeze - slowed them down enough in development that my going into lockdown and upping the humidity killed them? The two that did hatch (albeit with one dead before getting all the way out of the shell) could have been laid only min. before they were given to us so never got chilled all the way like the others did.

    I know its not much of a mystery in the great scheme of things but its been really bothering me, its not my first hatch by any means but its my first utter disaster with only one chick to be had from 15 eggs and half of those were my 6 year olds very first eggs for 4H. It wasnt one of those that hatched either [​IMG]
     
  2. Gypsy07

    Gypsy07 Chillin' With My Peeps

    2,286
    25
    193
    Feb 4, 2010
    Glasgow, Scotland
    If you've had good hatches before and you didn't do anything different this time then I'd guess the weather might have been something to do with it. Either that or your gauges are off maybe...
     

BackYard Chickens is proudly sponsored by