What did I do?

Discussion in 'Incubating & Hatching Eggs' started by QChickieMama, Aug 19, 2013.

  1. QChickieMama

    QChickieMama Chillin' With My Peeps Premium Member

    304
    2
    136
    Oct 1, 2011
    I set 24 eggs, candled them & removed the non-fertile and non-developing ones. Had 16 left. Seemed like all was great. Had 3 hatch a few days early. (These are australorps.) Now it's 2 days after calculated hatch date, and no more hatching. All 13 are just sitting. 70% rh, 100 degrees. Not opening incubator except to remove 3 hatchlings. I'm so sad. Was hoping for a bunch. What are the options for what went wrong?
     
  2. bugglesmommy

    bugglesmommy Chillin' With My Peeps

    With incubating, there are a ton of things that could go wrong.

    How old were the eggs when you set them? Local or shipped?

    Did you calibrate the thermometer? If you early hatching could indicate high incubation temps. Also, the other eggs may have shrink wrapped when you removed the 3 hatched ones. You may now want to candle and float the remaining eggs. If they are no longer viable, eggtopsy could give you some clues.
     
  3. QChickieMama

    QChickieMama Chillin' With My Peeps Premium Member

    304
    2
    136
    Oct 1, 2011
    They were my eggs from 1.5yo hens & 1yo roo. Not sure how to calibrate thermometer. If I have 2, & they aren't the same, how to know which one is correct?
     
  4. bugglesmommy

    bugglesmommy Chillin' With My Peeps



    Here is a video to help you calibrate.
     

BackYard Chickens is proudly sponsored by