Why!!!!!!!!!

Discussion in 'Peafowl' started by goofy98, Sep 27, 2011.

  1. goofy98

    goofy98 Chillin' With My Peeps

    172
    0
    89
    Sep 25, 2011
    Prineville
    I had some eggs but my incubator killed them all. At first it was to hot then I didn't even totch it and it went down and went up. Then I cheked them and they started to grow but then I saw a nasty bubel looking thing in it with them thats when I could tell they where dead I was so mad and they where all fertilized [​IMG] it is so hard to get fertile peacock eggs [​IMG] and ther where like 12 in the incubator. [​IMG]
     
  2. deerman

    deerman Rest in Peace 1949-2012

    9,491
    30
    293
    Aug 24, 2008
    Southern Ohio
    What kind of incubator ?

    Sorry about you losing them all........that sounds like temp. got to high.


    When incubating any type of eggs , i think the big killer is high temp. better to cool than to hot, at least will cool temp. a few will hatch. to hot will kill them ALL.
     
  3. goofy98

    goofy98 Chillin' With My Peeps

    172
    0
    89
    Sep 25, 2011
    Prineville
    I think it was a TX-6 if it isn't here it a pic


    [​IMG]
     
  4. deerman

    deerman Rest in Peace 1949-2012

    9,491
    30
    293
    Aug 24, 2008
    Southern Ohio
    Wow those are great incubators ,i have 3 of them. is it still overheating, bad thermostat ?.. Must keep them out of sunlight, they normal are great at holding temps.
     
  5. goofy98

    goofy98 Chillin' With My Peeps

    172
    0
    89
    Sep 25, 2011
    Prineville
    no it was a rent [​IMG]
     
  6. peafowlmom

    peafowlmom Chillin' With My Peeps

    316
    2
    103
    Jul 20, 2011
    Summerville ,SC
    I am very sorry for your loss![​IMG]
     

BackYard Chickens is proudly sponsored by